Câu hỏi Làm cách nào để khắc phục sự cố không dây chậm trên các máy có thẻ không dây Intel?


Tôi đã xem xét tất cả các câu hỏi trước nhưng việc tắt quản lý nguồn điện cho thẻ Wi-Fi không hoạt động. Vấn đề này có vẻ là với Lenovo Thinkpads. Tôi chuyển sang Ubuntu 11.10 từ Windows 7 3 ngày trước vì vậy tôi mới vào hệ điều hành.


21
2018-04-07 00:18


gốc


có cùng một vấn đề - kết nối không dây cực kỳ chậm - trên một chiếc điện thoại thinkpad e420s. có thể bạn sẽ gặp vấn đề tương tự với thẻ intr centrino; gõ sudo lspci -nn trong một thiết bị đầu cuối và xem "bộ điều khiển mạng". nếu bạn có thẻ này, hãy xem báo cáo lỗi tại đây: bugs.launchpad.net/ubuntu/+source/linux/+bug/836250 - eskararriba
tốt, bạn có thể cho tôi biết những gì các hướng dẫn thực sự làm? những hướng dẫn này cho một card không dây cụ thể là gì? nếu bạn đưa ra câu trả lời cụ thể hơn một chút, bạn có thể đăng câu trả lời cho câu hỏi của riêng mình và chấp nhận câu hỏi đó :) - amc
Bạn đã giải quyết câu hỏi này chưa? - pl1nk
Tôi đã làm theo các hướng dẫn cuối cùng trong bài này. Nó giải quyết vấn đề trên Shuttle XS35 của tôi (Atom D510) với Ubuntu 12.04 với tốc độ đói từ 0,91 Mbps đến 8,74 Mbps (nhanh hơn 9 lần). - cblanquer
Tôi không hiểu tại sao không ai ở đây làm phiền giải thích tất cả các lệnh này thực sự làm gì? Gửi hướng dẫn như "trên ubuntu x.xx sao chép mã này vào một thiết bị đầu cuối" là không hữu ích ở tất cả, phải không? Nếu bạn không thể đưa ra lời giải thích, xin đừng trả lời. - jan groth


Các câu trả lời:


OP đã đăng:

  • Lưu ý 1: Kết nối chậm có thể do nhà cung cấp dịch vụ của bạn hoặc bất kỳ lý do nào khác, để kiểm tra nó, hãy thử cùng một mạng bằng bất kỳ máy tính nào khác với hệ điều hành khác hoặc kết nối với mạng bằng cáp. Nếu nó nhanh, giải pháp này có thể giúp bạn. Nếu không, nó có thể lãng phí thời gian! *

  • Lưu ý 2: Trong liên kết đầu tiên trong Tài liệu tham khảo tôi đặt, có nhiều phương pháp để giải quyết kết nối không dây chậm. Mỗi phương pháp giải quyết các lý do khác nhau có thể có của kết nối chậm. Tôi khuyên bạn nên kiểm tra các giải pháp tôi đặt ở đây trước khi tìm kiếm các phương pháp khác nhau bởi vì nó có lẽ là hiệu quả nhất. *


Nếu bạn đang sử dụng Ubuntu 11.10, hãy làm như sau:

thiết bị đầu cuối mở. Nhập hai dòng sau:

sudo rmmod -f iwlagn
sudo modprobe iwlagn 11n_disable=1

Bây giờ, hãy kiểm tra tốc độ Internet không dây của bạn. Nếu nó vẫn còn chậm, giải pháp này có lẽ không phải là một giải pháp cho trường hợp của bạn. Trong trường hợp này, chỉ cần khởi động lại máy tính để hoàn nguyên thay đổi bạn đã thực hiện. Nếu nó trở nên bình thường và nhanh chóng, hãy làm điều đó vĩnh viễn bằng cách gõ dòng sau vào terminal:

gksudo gedit /etc/modprobe.d/iwlagn-disable11n.conf

Một tệp sẽ được mở. Ở cuối tệp, dán dòng sau rồi lưu:

options iwlagn 11n_disable=1

Sau khi lưu, chỉ cần thoát, và ENJOY!


Giải pháp cho Ubuntu 12.04:

thiết bị đầu cuối mở. Nhập hai dòng sau:

sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Bây giờ, hãy kiểm tra tốc độ Internet không dây của bạn. Nếu nó vẫn còn chậm, giải pháp này có lẽ không phải là một giải pháp cho trường hợp của bạn. Trong trường hợp này, chỉ cần khởi động lại máy tính để hoàn nguyên thay đổi bạn đã thực hiện. Nếu nó trở nên bình thường và nhanh chóng, hãy làm điều đó vĩnh viễn bằng cách gõ dòng sau vào terminal:

gksudo gedit /etc/modprobe.d/iwlwifi-disable11n.conf

Một tệp sẽ được mở. Ở cuối tệp, dán dòng sau rồi lưu:

options iwlwifi 11n_disable=1

Sau khi lưu, chỉ cần thoát, và ENJOY!


Tham khảo:

* Tôi đã thử cả hai giải pháp và họ làm việc.


20
2018-04-11 01:14



Tôi phải lưu ý rằng giải pháp này hoạt động cho kết nối wifi chia sẻ quá. Tôi đã có tốc độ uplink khoảng 2Mbits, nhưng chia sẻ wifi chậm như 40kbit. Làm điều này trên cả hai máy đều hoạt động. (có lẽ máy leecher đã đổ lỗi) - culebrón
Vẫn còn hiệu lực cho 14,10. Nếu bạn nhận được "L ERI: Mô-đun iwlwifi đang được sử dụng bởi: iwlmvm", hãy sử dụng "sudo rmmod iwlmvm" - Turtles Are Cute
Sau khi sử dụng modprobe, tôi không thể kết nối với mạng không dây. Hóa ra Tôi đã làm điều này để có được xung quanh một lỗi khác, nhưng sau đó, điều này chắc chắn đã giải quyết được vấn đề của tôi. - Izkata


Tôi đã tự giải quyết vấn đề này bằng cách sử dụng hướng dẫn đây.

trong một thiết bị đầu cuối, viết:

echo "options iwlagn 11n_disable=1" | sudo tee /etc/modprobe.d/iwlagn.conf
sudo modprobe -rfv iwlagn
sudo modprobe iwlagn

Từ 12.04 trở lên: thay đổi options iwlagn 11n_disable=1 đến options iwlwifi 11n_disable=1


10
2018-04-30 18:52



Tôi không biết điều này làm gì nhưng nó hoạt động. bạn thật tuyệt vời, cảm ơn bạn! - Kaine McAliece
Đã phải khởi động lại để nó hoạt động và sau đó nó hoàn hảo! - miguelv
Tôi không có một iwlagn.conf trong modeprobe.d, tôi có nên tạo nó không? btw Tôi đang sử dụng 12.04 - shengy
"Đối với 12.04, thay đổi tùy chọn iwlagn 11n_disable = 1 thành tùy chọn iwlwifi 11n_disable = 1" - ok, nhưng chúng ta vẫn nên chỉnh sửa iwlagn.conf hoặc iwlwifi.conf? - sylvainulg
Đối với hồ sơ, điều đó vô hiệu hóa "n" hương vị của giao thức 802.11 (aka WiFi), đó là lỗi trên chipset intel. Kiểm tra đầu ra của "iwconfig wlan0" trước và sau khi phát hành các lệnh đó. Nó sẽ bắt đầu với "IEEE 802.11abgn" trước và chỉ "802.11abg" sau. - sylvainulg


Đối với 12.04, thay đổi:

options iwlagn 11n_disable=1

Đến:

options iwlwifi 11n_disable=1

4
2017-08-01 22:07





Lỗi này ảnh hưởng đến máy tính xách tay của tôi với Centrino Ultimate-N 6300. Điều duy nhất đã giúp là bật tham số swcrypto. Của tôi /etc/modprobe.d/iwlwifi.conf bây giờ trông như thế này:

options iwlwifi 11n_disable=1 led_mode=1 swcrypto=1

Và tôi có thể sử dụng wifi mà không gặp vấn đề gì. Tuy nhiên, thực tế là n-mạng không thể được sử dụng vẫn còn gây phiền nhiễu.


3
2017-11-04 02:48



Điều này đã được sửa chữa trong Ubuntu 15 chưa? - Jonathan


Các lệnh này đã giúp và làm việc cho tôi, Kubuntu 15,10 (wily), Bộ điều hợp Wifi Intel của tôi (Tập đoàn Intel Centrino Wireless-N 1000) đã đi đến tốc độ tối đa toàn phần từ việc thu thập thông tin (tốc độ ốc sên):

echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/iwlagn.conf
echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe iwlwifi
apt-get update

Ban đầu tôi gặp nhiều khó khăn để tìm ra điều này, tôi hy vọng nó giúp ai đó ở đó, ban đầu nó rất chậm, khi tôi cài đặt Linux (Kubuntu), điều đó khiến tôi phát điên :)


2
2017-11-07 06:02



Wifi của tôi cutout một lần nữa và tôi đã nghiên cứu thêm để tìm ra rằng bạn có thể chỉnh sửa dòng để: tùy chọn iwlwifi 11n_disable = 1 bt_coex_active = 0 power_save = 0 auto_agg = 0 swcrypto = 1 - David V.
Tôi đã tạo một tệp văn bản trong thư mục tài liệu có tên iwlwifi.conf và thêm các lệnh ban đầu và dòng được thêm vào được đề cập trong chú thích trước đó để đọc: # /etc/modprobe.d/iwlwifi.conf # iwlwifi sẽ tải tải xuống iwldvm hoặc iwlmvm tùy thuộc vào tập tin # microcode được cài đặt trên hệ thống. Khi loại bỏ iwlwifi, đầu tiên # loại bỏ các mô-đun iwl? Vm và sau đó iwlwifi. xóa iwlwifi \ (/ sbin / lsmod | grep -o -e ^ iwlmvm -e ^ iwldvm -e ^ iwlwifi | xargs / sbin / rmmod) \ && / sbin / modprobe -r mac80211 tùy chọn iwlwifi 11n_disable = 1 bt_coex_active = 0 power_save = 0 auto_agg = 0 swcrypto = 1 - David V.
Sau đó lưu tài liệu và chạy konsole và nhập lệnh su cp /home/[replaceyourusernamehere]/Documents/iwlwifi.conf /etc/modprobe.d/iwlwifi.conf Sau đó wifi của tôi bắt đầu hoạt động nhanh hơn trước khi tôi vừa nhập: tùy chọn iwlwifi 11n_disable = 1 - David V.
**** Tôi KHÔNG LÀM PHẦN NÀY DƯỚI ĐÂY NHƯNG CÓ THỂ LÀM VIỆC **** Bạn có thể vẫn cần chạy các lệnh như: tùy chọn tùy chọn echo echo iwlwifi 11n_disable = 1 bt_coex_active = 0 power_save = 0 auto_agg = 0 swcrypto = 1 | sudo tee /etc/modprobe.d/iwlwifi.conf sudo modprobe -rfv iwlwifi sudo modprobe iwlwifi apt-get cập nhật Tôi vẫn nhận được mô-đun lỗi iwlwifi đã được sử dụng khi tôi chạy trước đó: sudo modprobe -rfv iwlwifi. Hãy cho tôi biết nếu điều này làm việc cho bạn hay không trong các ý kiến. - David V.


CẬP NHẬT: Nó bằng cách nào đó đã kết thúc không kết nối một lần nữa vì vậy tôi đã nghiên cứu thêm ở đây là những gì tôi tìm thấy:

Khôi phục bản gốc iwlwifi lệnh trong tệp iwlwif.conf (có thể không cần thiết để khôi phục các lệnh gốc trong iwlwifi.conf trong tập tin /etc/modprobe.d/iwlwifi.conf và dán dòng này vào cuối:

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1

Để khôi phục tệp, bạn có thể tạo tệp văn bản mới trong tài liệu có tên iwlwifi.conf và thêm các dòng lệnh:

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1

Sau đó lưu tài liệu và chạy konsole và nhập các lệnh

sudo cp /home/[replaceyourusernamehere]/Documents/iwlwifi.conf /etc/modprobe.d/iwlwifi.conf

Sau đó wifi của tôi bắt đầu hoạt động nhanh hơn trước đây khi tôi vừa mới nhập:

options iwlwifi 11n_disable=1

Lưu ý: ở trên chỉ làm việc cho tôi, nơi tôi sao chép các tập tin bằng cách sử dụng superuser. Tôi không làm phần này dưới đây nhưng nó có thể hoặc có thể không hoạt động.

Bạn có thể vẫn cần chạy các lệnh như sau:

echo options options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe iwlwifi
apt-get update

Tôi vẫn nhận được mô-đun lỗi iwlwifi đã được sử dụng khi tôi chạy trước đây:

sudo modprobe -rfv iwlwifi.

Hãy cho tôi biết nếu điều này làm việc cho bạn hay không trong các ý kiến.


1
2017-12-20 16:47



Để trở thành superuser bạn cần chạy lệnh: sudo passwd root - David V.


Mở một thiết bị đầu cuối (Alt+Ctrl+T) và gõ:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Bây giờ kiểm tra xem tốc độ đã được cải thiện chưa. Nếu có, hãy để nó vĩnh viễn.

  1. Mở /etc/modprobe.d/iwlwifi_disable11n.conf là siêu người dùng, e. g .:

    gksudo gedit /etc/modprobe.d/iwlwifi_disable11n.conf
    
  2. Thêm dòng sau vào cuối tập tin:

    options iwlwifi 11n_disable=1
    
  3. Sau đó, lưu nó và bỏ thuốc lá!

Trong trường hợp bạn gặp lỗi như

ERROR: Removing 'iwlwifi': No such file or directory

thay thế iwlwifi với iwlagn trong các lệnh trên và thử lại.


1
2018-05-23 01:15





Sau nhiều năm không thể sử dụng 801.11n trên máy tính xách tay của tôi. Tôi tìm thấy một giải pháp thực sự khắc phục vấn đề này! Điều này có vẻ là giải pháp tốt nhất có thể bởi vì bạn vẫn có thể sử dụng bluetooth và cũng có thể truy cập mạng qua 801.11n mà không gặp bất kỳ sự cố nào (tôi nhận được ~ 70Mb / giây).

Nhập các lệnh sau vào một thiết bị đầu cuối:

echo options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8 | sudo tee /etc/modprobe.d/iwlwifi-disable11n.conf

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi

Dưới đây là giải thích về những gì chúng tôi đang thực hiện:

  • swcrypto=1 chuyển mã hóa phần cứng để mã hóa phần mềm.
  • bt_coex_active=0 tắt tính năng tự động can thiệp giữa bluetooth và wifi tắt - đây có thể là nguyên nhân chính gây ra sự cố.
  • 11n_disable=8 cho phép tập hợp TX AMPDU.

bt_coex_active thực sự làm khi nó được kích hoạt về cơ bản là "tắt" wifi bất cứ khi nào hệ thống nghĩ rằng tần số bluetooth đang được sử dụng - nhưng trong triển khai buggy, nó giả định rằng bluetooth luôn truyền, do đó đóng nắp wifi vĩnh viễn.

Hầu hết mọi người chọn thay đổi tệp mặc định /etc/modprobe.d/iwlwifi.conf nhưng cá nhân tôi thích đặt nó vào một tập tin riêng biệt để nó có thể được hoàn tác nếu cần thiết. Nếu bạn đã thử các chỉnh sửa trước đó, vui lòng kiểm tra xem tệp của bạn đã được hoàn nguyên về cài đặt mặc định hay chưa. Đối với mỏ tham chiếu là (trên Ubuntu 16.04):

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

Nếu điều này không hiệu quả với bạn, hãy chạy:

sudo rm /etc/modprobe.d/iwlwifi-disable11n.conf

Nguồn:

https://superuser.com/a/924560/135819

Cách sử dụng của tôi (milage của bạn có thể thay đổi):

  • Hệ điều hành: Ubuntu 16.04 (sẽ hoạt động trên phiên bản mới hơn và cũ hơn!)
  • Phần cứng: Tập đoàn Intel Centrino Wireless-N 1000 [Condor Peak] (nhưng sẽ hoạt động trên các kiểu máy tương tự, ví dụ: Intel Centrino 6235!)

0