Câu hỏi Sự cố khi nâng cấp Ubuntu 12.10 lên 13.04


Tôi đang cố gắng nâng cấp bản phát hành Ubuntu từ 12.10 lên 13.04, đã nâng cấp thành công lên 12.10 ngày hôm qua. Với ý định sau đó chuyển đến 13,10.

Tôi cập nhật các bản cập nhật phần mềm khác.

Sử dụng Trình quản lý cập nhật Tôi được cung cấp để nâng cấp bản phát hành, nhưng điều này là nâng cấp lên 13,10 thay vì dự kiến ​​13,04.

Khi chọn nâng cấp, điều này thực sự cố gắng nâng cấp lên 13,10 'Saucy', ứng dụng sẽ cho tôi biết làm như vậy, đúng như vậy và gửi tôi đi.

Bất kỳ ý tưởng làm thế nào tôi có thể nâng cấp lên 13.04 trước hết?


1
2017-12-17 23:15


gốc


Nếu bạn đang được cung cấp 13,10 thì bạn phải ở trên 13.04. Bạn cũng không thể nâng cấp trực tiếp từ 10.10 lên bất kỳ thứ gì trừ 11.04, cả hai đều đã hết hạn và không được hỗ trợ trong một khoảng thời gian, ngăn chặn nâng cấp trừ khi bạn đi ra ngoài để kích hoạt kho lưu trữ lỗi thời. - psusi
Xin chào psusi, cảm ơn bạn đã trả lời. xin lỗi đã thông báo sai trước đây, tôi thực sự vào ngày 12.10, đã kiểm tra trên thiết bị đầu cuối sau thông tin phát hành được cung cấp: Nhà phân phối ID: Ubuntu Mô tả: Ubuntu 12.10 Release: 12.10 Codename: quantal - Lee


Các câu trả lời:


Bạn phải sử dụng update-manager-core từ quantal-updates thay vì quantal-proposed.

Xem: Tôi không biết cách nâng cấp từ 12.10 lên 13.04 hoặc 13.10


1
2017-12-20 15:48



Andreas - cảm ơn câu trả lời của bạn, đã làm việc với nhau. được cập nhật thành 13.04 như được đề xuất bằng cách sử dụng cập nhật-người quản lý-core. Sau đó, 13.10 thông qua trình quản lý cập nhật. Cảm ơn nhiều. - Lee


Tình hình dứt khoát xung quanh vấn đề này là gói quản lý cập nhật không hỗ trợ nâng cấp cho saucy .. tốt, như hiện nay.

Có lẽ nó đã làm như vậy trong quá khứ, và có lẽ nó có thể làm như vậy một lần nữa trong tương lai. Nhưng tính đến tháng 4 năm 2014, công cụ này không hỗ trợ nâng cấp lên chương trình saucy. Có lẽ điều này có thể là do EOL'ing of Raring (13.04) .. và có lẽ cũng cần phải nâng cấp trực tiếp từ 12.10 lên 13.10.

Điều duy nhất làm việc cho tôi là:

  • s / quantal / saucy / trong /etc/apt/sources.list
  • apt-get update
  • apt-get dist-upgrade

1
2018-04-15 11:57





Điều này sẽ làm những gì bạn nên làm:

sudo apt-get -y dist-upgrade

điều này sẽ nâng cấp tất cả các tệp phụ thuộc của bạn, dễ dàng hơn theo cách đó trước khi nâng cấp lên Saucy. Lệnh tiếp theo này sẽ cho phép bạn chuyển sang Saucy:

sudo do-release-upgrade

thì điều đó sẽ kích hoạt quá trình. Chúc may mắn!


0
2017-12-17 23:25



Chào Faron, cổ vũ cho phản ứng. Tôi đã cố gắng này nhưng sau thông báo lỗi được trả lại sau khi sudo do-phát hành-nâng cấp (ps tôi khuyên không chính xác về những gì phiên bản tôi hiện đang ở trên): Không thể nâng cấp Một nâng cấp từ 'lượng tử' đến 'saucy' không được hỗ trợ với điều này dụng cụ. - Lee


Điều này được mong đợi, nhưng không quá sớm. Raring sẽ là EOL (End Of Life) từ tháng 1 năm 2014 trở đi, nhưng Quantal (mà bạn đang sử dụng) sẽ vẫn được hỗ trợ cho đến tháng 4 năm 2014. Vì vậy, nhóm phát hành đã làm gì:

Vì vậy, thay vào đó đường dẫn nâng cấp được hỗ trợ sẽ là 12.10-> 13.10-> 14.04, bắt đầu từ tháng 1.

Bạn có thể cảm thấy điều này. Họ có lẽ (tôi chưa tìm thấy nguồn nào) đã kích hoạt từ phía máy chủ trước khi bàn tay. Tôi không biết nếu hành vi như vậy có thể được tinh chỉnh (từ phía khách hàng) và tôi sẽ không thử nghiệm với nó. Bạn có thể thử nâng cấp, nếu nó hoạt động, tuyệt vời! Nếu không, vui lòng báo cáo lỗi. Đảm bảo tạo bản sao lưu tất cả nội dung của bạn trước khi nâng cấp!

Liên quan:


0
2017-12-18 21:58



Hi Braiam, cố gắng nâng cấp và trả về lỗi: lee @ lee-Aspire-5720: ~ $ sudo do-release-upgrade Kiểm tra bản phát hành Ubuntu mới Nhận: 1 Chữ ký công cụ nâng cấp [198 B] Nhận: 2 Công cụ nâng cấp [1,135 kB ] Đã tìm nạp 1,135 kB trong 0 giây (0 B / s) xác thực 'saucy.tar.gz' chống lại 'saucy.tar.gz.gpg' extracting 'saucy.tar.gz' Bộ nhớ cache đọc Kiểm tra trình quản lý gói Không thể nâng cấp Nâng cấp từ 'lượng tử 'to' saucy 'không được hỗ trợ với công cụ này. - Lee
"Nâng cấp từ 'lượng tử' thành 'saucy' không được hỗ trợ với công cụ này"Tôi nghĩ điều này có thể là vấn đề. Hãy thử với trình quản lý cập nhật thay thế. - Braiam
Trình quản lý cập nhật hiển thị cùng một lỗi khi cố gắng.upgrade. nó cho thấy tôi đang trên 12.10 khuyên một phiên bản mới 13.10 có sẵn nhưng sau đó trả về lỗi này. Tôi không vội vàng để có được sắp xếp này, vì vậy sẽ treo cho đến khi janary khi 13.04 là chính thức EOL và thất bại. Đó là một cài đặt sạch sẽ để 13.10 - Lee
@Braiam Xin vui lòng xem câu trả lời của tôi ở đây: askubuntu.com/questions/390587/… cho một giải pháp cho vấn đề "không được hỗ trợ với công cụ này". - intgr


Tôi đã có cùng một vấn đề và đây là cách tôi quản lý để nâng cấp 12,10-13,04 thay vì 13,10:

1) Mở tệp nâng cấp bản phát hành: sudo gedit /etc/update-manager/release-upgrades
2) Bạn nên có Prompt=normal, chế độ này nâng cấp để phát hành ngay lập tức thành công phiên bản hiện đang chạy.
3) Chạy nâng cấp bằng sudo do-release-upgrade

Bằng cách này tôi bây giờ có 13.04, không phải là 13.10.


0
2018-01-29 12:27