Câu hỏi Làm thế nào tôi có thể tắt Bluetooth khi khởi động hệ thống?


Làm thế nào tôi có thể tắt Bluetooth khi khởi động hệ thống?


277
2017-10-16 21:02


gốc


Tôi không nghĩ rằng "nên là cấu hình mặc định tự nhiên", mọi người nhất định muốn sử dụng Bluetooth trên máy tính của họ mà không phải bật tính năng này (bạn dường như không có chuột hoặc bàn phím Bluetooth, nếu đó là thiết bị đầu vào chính bạn muốn bật Bluetooth từ khi khởi động). Tuy nhiên tôi đồng ý rằng một cách để chọn cách bạn muốn Bluetooth được khởi động sẽ hữu ích để có. - roadmr
Điều bình thường và tự nhiên là để cho phép bạn chọn, trong cài đặt bluetooth, cho dù bạn muốn bật hay tắt khi khởi động. Nó không phải là tự nhiên để có người tắt nó đi hoặc trên mỗi khi họ bật máy tính của họ. Chúng tôi đang nói về việc làm cho Linux trở thành hệ thống máy tính để bàn tốt nhất, không phải là tồi tệ nhất, phải không? - Robert
Chúng tôi đồng ý rằng để mọi người chọn là lựa chọn tốt nhất. Xem ở đây để biết một số cách thực hiện điều này. answers.launchpad.net/ubuntu/+source/bluez/+question/51440 - roadmr
Đây là lỗi # 1073669. - colan
Không thể tin được rằng, trên ấn bản thứ 14, chúng tôi vẫn "dạy" các nhà phát triển Ubuntu những thứ như "tùy chọn bật hoặc tắt bluetooth khi khởi động nên có sẵn cho người dùng bình thường, và không chỉ cho những người thích tìm kiếm trong các dòng liên tục của các diễn đàn công cộng ". - Rodrigo


Các câu trả lời:


18.04+ người dùng không tự nhiên có /etc/rc.local, bạn cần phải tạo một /etc/rc.local và làm cho nó có thể thực thi được. Để làm cho mọi việc dễ dàng hơn một chút, bạn có thể chỉ cần dán lệnh sau vào một thiết bị đầu cuối:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Chạy sudoedit /etc/rc.local và thêm dòng này vào trước exit 0:

rfkill block bluetooth

Bạn vẫn có thể bật Bluetooth thông qua applet trên thanh.

Điều này Nên làm việc cho hầu hết các hệ thống nhưng có vẻ như có một vài lỗi ẩn trong ACPI của hạt nhân cho Thinkpad. Nếu bạn đang sử dụng Thinkpad, hãy thêm thông tin sau vào /etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Hoặc kiểm tra ibm-acpi - Trình điều khiển tiện ích bổ sung của IBM ThinkPad ACPI - một số báo cáo cho thấy rằng ibm-acpi bao gồm điều khiển bluetooth (trong số những điều tốt đẹp khác). Nhưng tôi không có phần cứng nên tôi hoàn toàn không thể xác minh những xác nhận quyền sở hữu này. Chúc may mắn.


189
2017-08-18 09:00



Đối với Thinkpads (và chỉ Thinkpad) hoạt động này: echo disable > /proc/acpi/ibm/bluetooth trong /etc/rc.local - Marius Gedminas
rfkill block bluetooth làm việc cho Thinkpad T430u - bmaupin
Không làm việc cho tôi (ThinkPad x201) khi tôi đặt chúng từng cái một /etc/rc.local. Các rfkill block bluetooth lệnh không hoạt động, nhưng không hoạt động. Cờ -x được đặt trên /etc/rc.local. Tôi đang chạy Xubuntu 13.10. - Kyle Falconer
Trên Ubuntu 15.10 với systemd bạn cần thêm một số thứ nữa để có thể sử dụng lại etc/rc.local tập tin: askubuntu.com/a/696226/34298 - rubo77
nếu rc.local của chúng tôi chỉ là một tập tin rỗng, chúng ta nên thêm 'rfkill block bluetooth' ở đâu? - Sss


Tôi đã tìm thấy cách thực hiện với cách giải quyết "sạch sẽ" đây (liên kết lưu trữ cho hậu thế)

Thực sự đang thay đổi /etc/bluetooth/main.conf là đủ cho tôi.

Từ bài viết:

Tìm kiếm mục:

InitiallyPowered = true

và thay đổi giá trị thành:

InitiallyPowered = false

Đó là đủ cho tôi, mặc dù bài viết mô tả một số bước khác mà có thể hoặc có thể không cần thiết.

Trên Ubuntu 17.10 và Ubuntu 18.04 tùy chọn InitiallyPowered đã được thay thế bằng AutoEnable


71
2018-06-25 18:00



không hoạt động với máy tính xách tay samsung 530u3b, bluetooth luôn bật sau khi khởi động lại và thức dậy - Maxim Kim
Điều này sẽ chỉ hoạt động nếu tôi cũng sử dụng câu trả lời của Saeed Zarinfam /etc/init.d/bluetooth stop trong rc.local. Có vẻ như khi dịch vụ khởi động, nó cũng mang lại sức mạnh cho bluetooth. Tôi cần cả hai để làm việc này. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
Đã không làm việc cho tôi trên thinkpad t420 - UpTheCreek
"Tìm kiếm mục nhập" là chính xác không sử dụng cho những người trong chúng ta có main.conf không chứa thông số này hoặc bất kỳ nhận xét nào cho biết vị trí mặc định của nó. Vì vậy, theo đó [Heading] chúng ta nên đặt nó? - underscore_d
Về trường hợp của tôi nó đã được AutoEnable = false, nhưng anyways +1 cho giải pháp đúng từ đúng nơi. - Arman Petrosyan


Để tắt trình điều khiển bluetooth khi khởi động:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

thêm vào:

blacklist btusb

Kích hoạt nó sau này chỉ nên là:

sudo modprobe btusb

23
2017-08-18 16:59



Cảm ơn cho rằng, điều đó dường như làm việc nhưng tôi đã cố gắng để tránh các công cụ dòng lệnh theo câu hỏi ban đầu của tôi. Bạn sẽ nghĩ rằng điều này sẽ đơn giản như đánh dấu vào một hộp để nó nhớ rằng tôi không muốn BT để bắt đầu tự động nhưng có vẻ như cách của nó phức tạp hơn thế. Với ổ đĩa Ubuntu cho thời gian khởi động nhanh hơn và tập trung vào tiêu thụ điện năng trong máy tính xách tay và netbook, tôi ngạc nhiên rằng điều này chưa bao giờ được giải quyết. Tôi đánh giá cao sự giúp đỡ mặc dù.
"Chạy gedit dưới dạng root và chỉnh sửa /etc/modprobe.d/blacklist.conf" <- ok, đó là dòng lệnh ít hơn cho ya? - maco
Hoạt động tốt trên Samsung Q35 với Ubuntu 13.10, trong khi phương pháp 'rfkill block bluetooth' thì không. Cảm ơn! - user27164
DELL E6410 hoạt động cho tôi. Tốt có thể chạy lại khi đang di chuyển mà không cần đặt lại. - Ruslan Gerasimov
Đừng bận tâm cố gắng "tránh các công cụ dòng lệnh" khi bạn định cấu hình hệ điều hành. Ctrl + Alt + T và một vài ctrl-shift-V (dán) quá nhiều để hỏi? - doug65536


Bước 1: Vào terminal và gõ lệnh sau để chỉnh sửa hệ thống /etc/rc.local tập tin:

gksudo gedit /etc/rc.local

Bước 2: Thêm dòng sau đây trước exit 0 hàng:

rfkill block bluetooth

16
2018-05-04 20:44



Đây là thiết lập khối mềm để bluetooth, tôi nghĩ rằng nó giống như tắt dịch vụ của mình và hoạt động tốt. - Smile.Hunter
@ Robert: $ man rfkill: "Tắt thiết bị tương ứng với chỉ mục đã cho."Mặc dù tên, nó chỉ vô hiệu hóa BT, chỉ cần thử lệnh rfkill block bluetooth trên thiết bị đầu cuối, bạn sẽ thấy biểu tượng chuyển sang màu xám. - Daniel


Từ ubuntu 16.04 trở đi systemd quản lý các dịch vụ khởi động như bluetooth ... để xem vấn đề trạng thái hiện tại sau trong thiết bị đầu cuối

sudo systemctl status bluetooth.service 

để tắt bluetooth khi khởi động vấn đề này

sudo systemctl disable bluetooth.service

sau đó trên khởi động lại bluetooth tiếp theo sẽ không hoạt động ... để cho phép vấn đề bluetooth

sudo systemctl enable bluetooth.service

12
2017-08-01 15:08



Điều này làm việc cho tôi, nhưng như là một tác dụng phụ, blueman-applet ngừng hoạt động. Nó bắt đầu, nhưng không xuất hiện trong khu vực chỉ báo, vì vậy không có cách nào nhanh chóng để bật bluetooth, chỉ trong thiết bị đầu cuối. - Yuri Gor
Trong Xubuntu, ít nhất, nếu bạn nhấp vào Blueman, nó có tùy chọn "Tắt Bluetooth Tắt". Tôi nghĩ rằng đây là những gì OP muốn tự động. Giải pháp của bạn loại bỏ hoàn toàn Blueman, khiến cho việc bật lại Bluetooth trở nên khó khăn hơn nếu muốn. - Adrian Keister
Đặt sudo systemctl vô hiệu hóa bluetooth.service && sudo systemctl ngừng bluetooth.service vào tập lệnh Tắt và chmod 755 trên đó. Làm tương tự cho sudo systemctl cho phép bluetooth.service && sudo systemctl khởi động bluetooth.service trong tập lệnh Bật. - Adrian Keister


Nhập thông tin sau vào thiết bị đầu cuối:

sudo gedit /etc/modprobe.d/blacklist.conf

Ở cuối tệp, thêm dòng:

blacklist bluetooth

Lưu tệp và khởi động lại - Bluetooth giờ đây sẽ bị tắt.


7
2017-10-16 21:25



Điều này sẽ không hoạt động trên máy tính của tôi ... - Floqqi
@Floqqi: Bạn có thể thử lại không? Tôi đã cập nhật câu trả lời của mình. - Nathan Osman
Đã thử khoảng 20 thứ trên bảng suy nghĩ ubuntu 12 của tôi, đây là mẹo duy nhất đã thực hiện thủ thuật. - OlivierBlanvillain


Bạn có thể thay đổi các dịch vụ bắt đầu lúc khởi động với sự trợ giúp của BUM.

Cài đặt nó: sudo apt-get install bum

Chạy: sudo bum

enter image description here 

Bỏ chọn hộp và nhấp Ứng dụng.


7
2018-05-05 00:09



Cảm ơn bạn, desgua, tôi đã suy nghĩ về loại công cụ này. Tôi đã sử dụng một số trong quá khứ nhưng họ trở nên lỗi thời và ubuntu mới, với nỗi ám ảnh tối giản của họ, đi kèm với không có gì của loại. Đây có phải là chỉ yo biết hoặc yo tốt nhất biết? - Robert
Có thể làm việc nhưng lúc đầu nó đã làm tôi thất vọng vì nó bắt đầu hiển thị bluetooth như không được kích hoạt lúc khởi động, tại sao? và không chạy khi rfkill, applet và hciconfig cho thấy nó đang chạy. Tôi tắt và bật nhưng bum tiếp tục hiển thị các dịch vụ như tắt. Tôi đã kích hoạt dịch vụ lúc khởi động nhưng trạng thái của dịch vụ vẫn tiếp tục sai. - Robert
xin lỗi không làm việc trên elementaryOS Freya - Hoang Tran
Tôi nhận được rất nhiều cảnh báo "sử dụng giá trị chưa được khởi tạo" khi nó chạy. Xin lỗi, không thể tin tưởng điều đó. - doug65536
Bây giờ, gói không có sẵn. Nó nói, Bum là ảo. - Satya Prakash


Tôi nghĩ rằng cách tốt nhất là tắt dịch vụ ngay từ đầu. Có một phương pháp chung để vô hiệu hóa các dịch vụ hoạt động hoàn hảo:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Điều đó làm việc cho Ubuntu 13.10 và có thể cho các phiên bản trước đó.


5
2018-01-18 09:49



cách bật bluetooth, trong khi sử dụng cài đặt được cung cấp sau này? nói rằng tôi muốn sử dụng nó chỉ trong 5 phút. mỗi 10 khởi động .. - b1r3k


Tôi thêm

"/etc/init.d/bluetooth stop"

vào

"/etc/rc.local" 

trước khi "thoát 0" lệnh cho khởi động với bluetooth tắt.


5
2017-08-23 13:00



điều này làm việc cho tôi, cảm ơn! - woohoo
Thao tác này đã xóa biểu tượng khay bluetooth nhưng để đèn báo bluetooth của tôi bật sáng (chỉ báo nguồn điện vẫn đang được gửi tới đài). Chỉnh sửa: điều này kết hợp với câu trả lời của Stepbaer (InitiallyPowered = false) đã làm cho tôi. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
điều này đã không hoạt động trên 64-bit Ubuntu 14.04 dell inspiron của tôi. Chỉ rfkill làm việc cho tôi. - faizal