Câu hỏi Video flash có màu xanh lam


Vấn đề

Sau khi cập nhật lên Ubuntu 12.04 từ Ubuntu 11.10, tất cả video vẫn là màu xanh dương, cho dù đang phát trong trình duyệt hay trình phát. Cùng một vấn đề xảy ra trong 11,10 là tốt.

Tôi đã cố gắng gỡ bỏ cài đặt tất cả Flash và cài đặt lại nhưng nó không có sự khác biệt.

Điều gì gây ra video Flash màu xanh lam?

Ubuntu 11,10 64bit

Ubuntu 12.04LTS 64 bit


Nó trông như thế nào

Blue flash videos


243
2018-03-29 18:42


gốc


bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/… - Somatik


Các câu trả lời:


Có một số gợi ý sai lệch và một số khuyến nghị sai ở đây, vì vậy hãy tóm tắt vấn đề là gì và giải pháp nào có.

TL; DR

Các phiên bản Ubuntu mới nhất kể từ 12.10 (Định lượng) chứa một phiên bản vá của thư viện. Nếu bạn vẫn gặp sự cố với video màu xanh lam (KHÔNG bao gồm Nhóm nam xanh nước biển), kiểm tra câu trả lời này - tên thư viện của Flash Player phải là libflashplayer.so nếu không libvdpau sẽ không áp dụng giải pháp thay thế. Bạn cũng có thể xem /etc/vdpau_wrapper.cfg tập tin. Ở đó bạn có thể vô hiệu hóa các cách giải quyết được áp dụng bởi libvdpau.

Nếu bạn có Oneiric (11.10) hoặc Precise (12.04), hãy cài đặt libvdpau đã vá:

sudo add-apt-repository ppa:tikhonov/misc
sudo apt-get update
sudo apt-get install libvdpau1

Nếu không, bạn có thể sửa đổi thư viện Flash Player:

cd /usr/lib/flashplugin-installer || cd /usr/lib/adobe-flashplugin/
sudo perl -pi.bak -e 's/libvdpau/lixvdpau/g' libflashplayer.so

Đọc toàn bộ bài đăng trước khi nhận xét.

Vấn đề

Flash Player kể từ phiên bản 11.2 sử dụng tăng tốc video phần cứng trên hầu hết các nền tảng. Thật không may là khả năng tăng tốc trong Linux không chỉ không được hỗ trợ mà về cơ bản bị hỏng. Flash Player hoán đổi màu sắc trong video theo các điều kiện sau:

  • Bạn đang sử dụng GPU Nvidia khá mới với VDPAU ủng hộ.
  • Bạn đang sử dụng phiên bản hiện tại của trình điều khiển nhị phân Nvidia (phiên bản cũ hơn không hỗ trợ VDPAU).
  • Bạn có libvdpau1 gói cài đặt.
  • Trình phát trên trang web sử dụng Video sân khấu - đó là lý do tại sao chỉ có YouTube và một vài người chơi khác bị ảnh hưởng.

Xem lời giải thích của Pierre-Loup Griffais từ Nvidia.

Đây không phải là một lỗi trong trình điều khiển Nvidia. Nvidia nhận thức được vấn đề này và họ đã tạo ra một giải pháp thay thế. Trình điều khiển Nouveau có lẽ không bị ảnh hưởng bởi vì hỗ trợ giải mã video chưa hoàn tất.

Đây không phải là lỗi trong libvdpau. libvdpau chỉ là một trình bao bọc cho phép trình phát video sử dụng giải mã VDPAU (xem Lời giải thích của Stephen Warren).

Đây không phải là lỗi cụ thể của Ubuntu. Các bản phân phối khác cũng bị ảnh hưởng, ví dụ: Arch.

Lỗi này rất có thể trong Flash Player - mặc dù Adobe cố đổ lỗi cho Nvidia và những người dùng không đủ năng lực. Đã có nhiều báo cáo về trình gỡ lỗi của Adobe, tất cả chúng đều bị từ chối là "Không thể tạo lại":

Sẽ không có bản sửa lỗi chính thức từ Adobe, kể từ khi Flash Player dựa trên NPAPI chỉ nhận các bản vá bảo mật cho đến năm 2017. Hy vọng rằng chúng tôi sẽ không cần Flash Player vào thời điểm đó.

Cách giải quyết

Sử dụng libvdpau 0,5

Có sẵn trong kho chính thức kể từ Ubuntu 12.10 libvdpau 0.4.1-6

Phiên bản libvdpau này bao gồm một giải pháp thay thế bởi Stephen Warren được mô tả dưới đây.

Xem thông báo phát hành

Cài đặt libvdpau đã vá (bản vá thích hợp)

Stephen Warren đã tạo bản vá đẹp cho libvdpau, phát hiện Flash Player và chỉ áp dụng cách giải quyết. Bản vá có thể được kiểm soát bằng /etc/vdpau_wrapper.cfg tập tin.

Bản vá lỗi libvdpau sửa màu và cho phép Flash Player sử dụng VDPAU cho lớp phủ phần cứng mà vẫn cung cấp một số lợi ích hiệu suất.

Để trình bao bọc hoạt động, cần phải nhận ra việc sử dụng Flash. Vì vậy, thư viện Flash phải được đặt tên libflashplayer.so và trình bao bọc plugin phải được bật trong Firefox (trong about:config, dom.ipc.plugins.enabled.libflashplayer.so và dom.ipc.plugins.enabled nên được đặt thành true).

Đối với chính xác (12.04) và Oneiric (11.10), bạn có thể cài đặt libvdapu đã vá từ PPA của Maxim Thikonov sử dụng các lệnh sau:

sudo add-apt-repository ppa:tikhonov/misc
sudo apt-get update
sudo apt-get install libvdpau1

Thay đổi sẽ có hiệu lực sau khi khởi động lại (hoặc có thể sớm hơn).

Ngăn Flash Player tìm kiếm libvdpau

(Thông qua Daniel Mario Vega trên Launchpad)

Định vị libflashplayer.so trong hệ thống của bạn - cho Ubuntu, nó có thể /usr/lib/adobe-flashplugin/ nếu bạn có adobe-flashplugin gói cài đặt, hoặc /usr/lib/flashplugin-installer/ cho flashplugin-installer gói. Tham khảo ý kiến ​​trình duyệt của bạn about:plugins nếu bạn gặp khó khăn khi tìm tập tin (một chút tinh chỉnh trong trường hợp Firefox có thể được yêu cầu).

Chạy các lệnh sau - giả sử bạn đã cài đặt flashplugin-installer, hoặc là adobe-flasplugin:

 cd /usr/lib/flashplugin-installer || cd /usr/lib/adobe-flashplugin/
sudo perl -pi.bak -e 's/libvdpau/lixvdpau/g' libflashplayer.so

Thay đổi có hiệu lực sau khi khởi động lại trình duyệt.

Điều này sẽ sửa đổi nhị phân Flash Player để tìm kiếm thư viện "lixvdpau" không tồn tại thay vì "libvdpau". Vì vậy, nó sẽ không cố gắng sử dụng trình bày VDPAU cả.

Lệnh tạo bản sao lưu libflashplayer.so.bak của nhị phân trong trường hợp bạn gặp phải bất kỳ vấn đề nào.

Bạn cần chạy lệnh này mỗi khi có bản cập nhật Flash Player vì thay đổi của bạn sẽ bị ghi đè.

Với cách giải quyết này, bạn có thể giữ tăng tốc HW, đã cài đặt libvdpau1 và rất dễ áp ​​dụng so với libvdpau vá.

Sử dụng Google Chrome với PepperFlash

Kể từ phiên bản 20, Google Chrome phân phối cùng Flash Player "Pepper" 11.3 với hỗ trợ PPAPI (thay vì 11.2 trên NPAPI được Firefox và cộng sự sử dụng). PepperFlash dường như không bị ảnh hưởng bởi vấn đề này vì nó dường như sử dụng tăng tốc phần cứng đầy đủ.

PepperFlash có thể được sử dụng với Chromium, nhưng tiếc là không có trình duyệt nào khác hiện hỗ trợ PPAPI.

Vô hiệu hóa tăng tốc phần cứng Flash Player

Cách khắc phục dễ dàng nhất và ít xâm nhập nhất là tắt Flash Player Tăng tốc HW trong cài đặt Hiển thị - nhấp chuột phải vào Flash, chọn Cài đặt…

Tuy nhiên, điều này không dễ dàng vì cửa sổ Settings không phản hồi dưới trình quản lý tổng hợp (Compiz, Unity chuẩn) và nếu trình duyệt hiển thị thanh cuộn.

Để tắt tăng tốc phần cứng, hãy mở bất kỳ video nào (ví dụ: trên YouTube) ở chế độ toàn màn hình và sau đó mở cửa sổ Cài đặt…. Hoặc bạn có thể tạm thời chuyển sang Unity 2D hoặc WM không phải tổng hợp khác.

Thay đổi này có hiệu lực sau khi làm mới.

Hạn chế: điều này vô hiệu hóa khả năng tăng tốc HW trong Flash Player ngay cả đối với các hoạt động bitmap và bitmap. Một số trò chơi và phim Flash có thể có hiệu suất kém hơn và / hoặc đồ họa kém hơn.

Gỡ cài đặt libvdpau

Nếu bạn muốn bật tính năng tăng tốc HW trong Flash Player, bạn có thể gỡ cài đặt libvdpau khỏi hệ thống, điều này có hiệu quả ngăn Flash Player sử dụng VDPAU.

Chạy:

sudo apt-get remove libvdpau1

Hạn chế: Máy tính để bàn (như Totem và Mplayer) sẽ không thể sử dụng giải mã video phần cứng. Điều này sẽ dẫn đến việc sử dụng CPU cao hơn trong khi phát lại. Ngoài ra, hiệu suất phát lại video có thể bị ảnh hưởng (ví dụ: các khung hình bị rớt hoặc hình ảnh được đóng băng hoàn toàn), đặc biệt nếu bạn có CPU chậm hơn và bạn đang xem video 1080p.

Bật giải mã video phần cứng Flash Player

Hầu hết người dùng đã báo cáo rằng điều này dẫn đến sự cố rất thường xuyên của Flash Player (có thể do vấn đề đồng thời trong giải mã) nhưng nếu bạn cảm thấy may mắn, hãy thử.

Đây cũng là phương pháp được sử dụng bởi Flash-Aid addon. Nó sẽ không làm cho nó tốt hơn.

Chạy:

sudo mkdir /etc/adobe
echo -e "EnableLinuxHWVideoDecode=1" | sudo tee /etc/adobe/mms.cfg > /dev/null

Điều này sẽ tạo tệp /etc/adobe/mms.cfg với EnableLinuxHWVideoDecode=1 Nội dung. Đây là cách duy nhất để thực sự buộc Flash Player giải mã video trên GPU và nó không được Adobe hỗ trợ chính thức.

Để hoàn tác thao tác này, hãy chạy:

sudo rm /etc/adobe/mms.cfg

để xóa tệp mms.cfg.

Bạn có thể cố gắng cải thiện hơn nữa sự ổn định của Flash Player với VDPAU_NVIDIA_NO_OVERLAY=1 biến môi trường, xem Diễn đàn Nvidia.

Thay thế trình phát Flash

(Theo khuyến cáo của bowser trên Launchpad)

Sử dụng FlashVideoReplacer Tiện ích bổ sung của Firefox, Literna Mágica hoặc giải pháp khác để thay thế người chơi chuẩn trong Flash bằng plugin trình phát video được nhúng (như Totem - totem-mozilla - hoặc VLC - mozilla-plugin-vlc). Không có Flash Player, không sao cả.

Vá libvdpau (vdpau_trace hack)

Có một bản vá không chính thức của Nvidia sửa lỗi Flash Player trên cấp độ libvdpau bằng cách hack vdpau_trace.

Lưu ý rằng bản vá nói trên của Stephen Warren về mặt kỹ thuật cao hơn và nên được sử dụng thay thế.

Các cách giải quyết khác

Các giải pháp sau đây sẽ chỉ hoạt động một phần hoặc có thể có một số vấn đề.

Bật HTML5 tại YouTube

Bật trình phát HTML5 tại http://www.youtube.com/html5 sẽ không hoạt động với tất cả các video; một số video YouTube chỉ không có sẵn cho trình phát HTML5 (ví dụ: do thiếu hỗ trợ quảng cáo). Tuy nhiên, video HTML5 thật tuyệt vời và bạn vẫn nên sử dụng nó.

Hạ cấp xuống Flash Player 11.1

lỗ hổng đã biết trong FP 11.1 được sửa trong 11.2. Nếu bạn muốn mạo hiểm nó, bạn nên biết những gì bạn đang nhận được vào.

Nếu bạn vẫn muốn hạ cấp, hãy thử Flash Player 10.3 vẫn được duy trì - bạn có thể tải xuống Bản lưu trữ của Adobe

Chuyển sang GPU khác

Có vẻ như rất ít GPU Nvidia không bị ảnh hưởng, đặc biệt là Quadro 2000 và GeForce GT 430. Cả hai đều có Bộ tính năng VDPAU C, nhưng nếu không, hầu hết các tính năng đặt C GPU cũng bị ảnh hưởng. Nếu bạn có bất kỳ GPU nào nói trên, hãy cho chúng tôi biết trên Launchpad liệu lỗi này có ảnh hưởng đến bạn hay không.


187
2018-03-31 20:22



Văn bản cực kỳ hữu ích và mang tính thông tin. Tôi đã khắc phục vấn đề trong openSUSE 12.2 của tôi bằng cách giải nén libvdpau.so.1.0.0 từ deb được tìm thấy trong kho lưu trữ đã đề cập launchpad.net/~tikhonov/+archive/misc vào / usr / lib64 của tôi - hoàn hảo. Cảm ơn bạn! - RushPL
GPU mới hơn chắc chắn có lỗi (với bộ tính năng C). Tôi là một trong nhiều người. - Victor
@Victor Có, tôi đã nhận thấy; đó là một lý thuyết và nó đã sai. Thật lạ lùng khi hai GPU đặc biệt (và rất khác) không bị ảnh hưởng, tôi có khuynh hướng nghĩ rằng các phóng viên đã bỏ lỡ điều gì đó, ví dụ: họ không có cài đặt libvdpau (báo cáo tiêu cực về Quatro 2000 đến từ đại diện của Adobe). - jnv
Cảm ơn bạn đã dành thời gian để giải quyết vấn đề và cung cấp nhiều giải pháp với giải thích cho từng vấn đề. Áp dụng các miếng vá libpauv1 làm việc tuyệt vời cho tôi, và tôi chỉ cần khởi động lại trình duyệt của mình để áp dụng giải pháp. Cảm ơn! - dusktreader
tôi đã đi với Prevent Flash Player from finding libvdpau giải pháp và xác nhận nó hoạt động. vị trí của libflashplayer.so tệp đã ở /usr/lib/mozilla/plugins/libflashplayer.so và cũng làm việc cho opera - ulkas


CẬP NHẬT: Làm ơn nhìn vào giải pháp này để sửa chữa đúng cách. Giải pháp được đề cập ở đây dẫn đến sự cố cho nhiều người đã thử nó.

Điều này là do lỗi trong phiên bản Flash mới mà Adobe từ chối khắc phục. Ngoài ra còn có một báo cáo lỗi trên Launchpad thảo luận về điều này (LP: # 967091). Lỗi này chỉ xuất hiện khi bạn sử dụng trình điều khiển nhị phân NVidia và đã cài đặt libvdpau. Khắc phục nhanh là thêm một số cài đặt bổ sung vào cấu hình Flash.

sudo mkdir /etc/adobe
echo -e "EnableLinuxHWVideoDecode=1\nOverrideGPUValidation=true" | sudo tee /etc/adobe/mms.cfg > /dev/null

Điều này khắc phục sự cố trong khi vẫn có phần cứng VDPAU. Thật không may có lẽ sẽ không có một phiên bản Flash mới để sửa lỗi này mà không cần cấu hình bằng tay vì phiên bản Flash giới thiệu lỗi này cũng là phiên bản Flash cuối cùng mà Adobe sẽ phát hành cho Linux.

Nếu điều này gây ra sự bất ổn cho bạn, hãy hoàn nguyên các thay đổi bằng cách xóa thư mục bạn đã tạo trước đó.

sudo rm -r /etc/adobe

hoặc bạn có thể thử giảm tập tin /etc/adobe/mms.cfg thành chỉ

OverrideGPUValidation=true

bằng cách chỉnh sửa bằng sudo gedit /etc/adobe/mms.cfg.


94
2018-03-30 19:26



Cảm ơn bạn đã giải quyết vấn đề này cho tôi trên Ubuntu 11.10 (adobe-flashplugin 11.2.202.228-0oneiric1). Đây không phải là phiên bản Flash mới nhất cho Linux, sẽ có bản cập nhật bảo mật và các phiên bản mới hơn sẽ đi kèm với Google Chrome. - Mateusz Stachowski
Việc bật các tính năng này trong mms.cfg khiến Flash bị lỗi thường xuyên đối với tôi. - blujay
Vâng, đã khắc phục vấn đề màu xanh nhưng bị treo rất thường xuyên - Hubro
Điều này khắc phục vấn đề với màu xanh lam, nhưng gây ra sự bất ổn cho tôi. - foh1981
Lệnh này làm cho plugin flash gặp sự cố thường xuyên đối với tôi. làm thế nào để bạn trở lại? - RockScience


Khắc phục (làm việc xung quanh)

Vấn đề:  Tất cả trình duyệt web flash player video có màu xanh lam

  • Chromium
  • Google Chrome
  • Firefox

Cả hai plugin flash khiến video flash xuất hiện đều có lớp phủ màu xanh, vì vậy hãy xóa.

  • Adobe - flashplugin
  • Flashplugin - trình cài đặt

Giải pháp (không hoạt động như cắm flash adobe nhưng nó hoạt động)

  • Cài đặt công viên chiếu sáng (cộng với mọi plugin trình duyệt) hoặc là
  • Cài đặt gnash (cộng với mọi plugin trình duyệt)

Có thể sửa chữa 1

Đã xóa: 

  • trình cắm trình duyệt gnash
  • plug-in trình duyệt gightspark
  • API giải mã và trình bày video cho Unix (thư viện) libvdpau1 
  • flashplugin - trình cài đặt

Cài đặt: 

adobe-flashplugin Khởi động lại trình duyệt, và nó làm việc cho tôi.

Có thể sửa chữa 2

Cài đặt: 

  • libvdpau1

Thiết lập flash

  • tắt tăng tốc HW trong Flash.

Mở trình duyệt của bạn và điều hướng đến một video flash (youtube, abobe flash site, vv) nhấp chuột phải, cài đặt và tắt Tăng tốc phần cứng.

Nếu bạn không thể tắt tăng tốc phần cứng, hãy đăng nhập vào môi trường Unity 2D.

L BUI: https://bugs.launchpad.net/ubuntu/+source/unity/+bug/968489

OBS: Trong trường hợp phải kiên trì. Khởi động lại máy.


51
2018-03-31 12:37



Đối với tôi chỉ đơn thuần là cài đặt libvdpau1 làm việc, sau khi một số giải pháp khác không. Tôi đang chạy Ubuntu 11.10 với trình điều khiển NVIDIA 295,33. - D Coetzee
libvdpau1 đã được cài đặt cho tôi trong Ubuntu 12.04 64 bit. Dù sao vô hiệu hóa tăng tốc phần cứng đã làm các trick cho tôi. Tôi đang sử dụng cùng một trình điều khiển Nvidia như @Derrick Coetzee, nhưng trên Chính xác với Gnome Shell. - titaniumtux
Tôi dường như không thể nhấp vào tùy chọn để tắt tính năng tăng tốc HW. - RolandiXor♦
Xóa libvdpau1 đã làm việc cho tôi trong Firefox và Chrome cho tất cả các trang web tôi đã thử nghiệm. Tôi có một thẻ Nvidia 440 GT nếu nó giúp. - Luis Alvarado♦
Nếu bạn không thể bỏ chọn tùy chọn Tăng tốc phần cứng trong cài đặt Flash, hãy thử tùy chọn này ở chế độ toàn màn hình - hãy truy cập ví dụ: YouTube, mở mọi video ở chế độ toàn màn hình và mở cài đặt Flash (Nhấp chuột phải> Cài đặt…); cửa sổ sẽ được đáp ứng. Nếu cửa sổ trình duyệt có thanh cuộn, hộp thoại cài đặt không phản hồi trong tổng hợp WM. - jnv


Ok, vì vậy đây là kinh nghiệm của tôi với việc giải quyết điều này (trên Ubuntu 12.04 64-bit, trình điều khiển nVidia):

  • Loại bỏ flashplugin-installer và cài đặt adobe-flashplugin (đã không sửa chữa nó)

Điều này làm việc cho đến khi khởi động lại. Nhưng tôi giữ adobe-flashplugin kể từ khi tôi đang trên 64-bit (tôi đã nhận được ấn tượng rằng nó hoạt động tốt nhất).

  • Thay đổi phiên bản trình điều khiển (đã không sửa chữa nó)

Lúc đầu, tôi đã có bản cập nhật nvidia-current, tôi đã thay đổi thành nvidia-current. Điều này không khắc phục được. Synaptic chỉ ra rằng các phiên bản trình điều khiển là như nhau, như của bài viết này (295,33).

  • Cài đặt phần bổ trợ Flash-Aid trong Firefox (cố định nó sắp xếp, nhưng không ổn định)

Điều này làm việc miễn là tôi kích hoạt tùy chọn tăng tốc phần cứng (không bị nhầm lẫn với tùy chọn bên dưới !!). Nó không quan trọng nếu tôi cài đặt plugin Flash từ kho hoặc bản beta từ Adobe. Tuy nhiên, trong khi sửa chữa màu xanh lam, plugin cực kỳ không ổn định và bị rơi liên tục trong khi tương tác với các đối tượng Flash.

  • Kích hoạt video HTML5 trên Youtube (sửa nó trên Youtube)

Mặc dù tôi chỉ gặp sự cố này trên video trên Youtube nhưng tôi không thể chắc chắn rằng các trang web và video khác không bị ảnh hưởng. Theo đề xuất của những người khác tại đây, hãy truy cập youtube.com/html5 nếu bạn muốn kích hoạt hoặc hủy kích hoạt video HTML5 trên Youtube.com.

  • Vô hiệu hóa tăng tốc phần cứng thông qua nhấp chuột phải vào video Flash (cố định nó)

Đây là những gì làm việc tốt nhất cho tôi (nhưng tôi đã phải đăng nhập với Unity 2D theo đề xuất của pst007x trong chủ đề này). Màu xanh lam đã biến mất và video ổn định. Tôi sợ rằng khối lượng công việc của CPU sẽ tăng nhưng trong thử nghiệm có và không có tăng tốc phần cứng, tôi có thể thấy không có thay đổi (tôi đã sử dụng video từ kênh Googles ở độ phân giải 1080p), video bắt đầu vào khoảng 40% và giảm xuống 20% ​​khi video được tải đầy đủ.


14
2018-03-31 01:53





Tuy nhiên, bản sửa lỗi nhanh của tôi về điều này, dành cho YouTube, là tham gia HTML5 beta.

Nó đã làm việc một điều trị ... Và từ những gì tôi có thể nhìn thấy, có vẻ như chỉ có YouTube được thực hiện bởi lỗi cũ này nuôi đầu xấu xí của nó một lần nữa ...

Nó thực sự tốt nhất để bắt đầu sử dụng HTML5. Bạn phải nhớ rằng Đèn flash đang trên đường ra khi nói đến Linux. Sau đó, tất cả chúng ta sẽ phải sử dụng Google Chrome và không có gì khác :(


9
2018-01-16 09:27



không hoạt động trên video có quảng cáo - waspinator


Tôi đã khắc phục sự cố này sau khi tháo trình phát flash và sau đó cài đặt lại flash bằng tay bằng cách tải xuống flash từ trang web của Adobe và cài đặt nó qua Trung tâm phần mềm Ubuntu.


4
2018-01-23 03:43





Tôi đã giải quyết vấn đề này (sử dụng Linux Mint Lisa, dựa trên Ubuntu Oneiric) bằng cách đưa trình điều khiển NVIDIA trở lại phiên bản 173.

Cập nhật: Thật không may, phiên bản trình điều khiển NVIDIA 173 tạo ra cùng màu xanh Video MP4 rằng phiên bản được đề xuất (cập nhật) của trình điều khiển NVIDIA hoạt động Video flash. Đó là một chút tức giận: Tôi có thể có cà phê của tôi quá lạnh hoặc quá ngọt.

Và một bản cập nhật khác: Tôi đã có thể khắc phục vấn đề MP4 trong Totem bằng cách truy cập Preferences và đẩy thanh trượt Hue sang bên phải. Nóng và không quá ngọt.


3
2018-03-30 13:11





Thử cái này:

sudo apt-get purge flashplugin-installer
sudo apt-get install adobe-flashplugin

3
2018-04-30 11:24



1 Tôi đã có cùng một vấn đề này một thời gian trước đây (10.04), và tôi khá chắc chắn rằng đây là cách tôi cố định nó. - Aaron
Thật không may các vấn đề vẫn còn. - enedene
OK, sau đó thử tắt tăng tốc phần cứng Flash với hướng dẫn được tìm thấy đây. - SirCharlo
Tôi có cùng một vấn đề, trên Youtube. Vimeo dường như làm việc. Chuyển sang HTML5 sẽ khắc phục sự cố trên Youtube. Tôi tạm thời sửa nó bằng cách dọn dẹp bộ cài đặt flashplugin và cài đặt adobe-flashplugin, nhưng vấn đề được trả lại sau khi khởi động lại. Để hủy kích hoạt tăng tốc phần cứng, điều đó là không thể đối với tôi kể từ khi trở lại. Tôi không thể tương tác với cửa sổ bật lên (một vấn đề kể từ 11.10 và bây giờ vào ngày 12.04). - foh1981
Nhấp chuột phải vào video youtube, cài đặt, tắt tính năng tăng tốc phần cứng. Đó là một giải pháp không may, nhưng đó là một công việc cho đến khi adobe quyết định sửa chữa nó. - enedene


Điều này có thể là một vấn đề nếu bạn có trình điều khiển Nvidia được cài đặt với phiên bản Flash mới nhất. Hãy thử nhấp chuột phải vào video Flash và tắt tăng tốc phần cứng từ cài đặt. Nó làm việc cho tôi.


2
2018-06-13 06:52





Tôi có cùng một vấn đề. Tôi đang sử dụng Linux 3.2.0-24-generic (32-bit), Flash (mới nhất) phiên bản 11.2.202.236 và Mozilla Firefox.

Tôi đã cố gắng hủy bỏ khả năng tăng tốc trong cài đặt chung - nó không khắc phục được. Tôi đã thử đặt lại cài đặt trình điều khiển Nvidia cho màn hình X của mình.

Không có vấn đề gì cả với màu sắc trong trình phát phim và có những video mà tôi có thể phát trên internet, không sao, nhưng không phải video trên YouTube.

Đang tạo tệp mms.cfg đã làm việc. Tuy nhiên nó đã loại bỏ các trình phát media và phát lại miro (video và phim chuyển sang màu xanh ở đó).

Sau đó tôi làm theo:

  1. Mở gstreamer-properties (Alt+F2, đi vào gstreamer-properties). Thay đổi sang tab video. Thay đổi plugin đầu ra mặc định thành "X Window System (X11 / XShm / Xv)". Đặt thiết bị '' Default ''. Kiểm tra và đóng hộp.

1
2018-05-06 23:46





Tôi đã gặp vấn đề này một lần nữa sau khi nâng cấp. Tôi đã tìm ra rằng enable_flash_uv_swap tùy chọn trong /etc/vdpau_wrapper.cfg để hoạt động, tệp thư viện Flash (hoặc liên kết tượng trưng) phải được đặt tên libflashplayer.so (Tôi đã flashplayer-alternative.so). Vì vậy, tôi vừa đổi tên flashplayer-alternative.so đến libflashplayer.sovà nó bắt đầu hoạt động.

Để biết thêm thông tin, hãy xem [ANNOUNCE] libvdpau 0,5:

Cách giải quyết này được áp dụng nếu "libflashplayer" được tìm thấy trong   / proc / self / cmdline và chuỗi "enable_flash_uv_swap = 1" được tìm thấy trong   /etc/vdpau_wrapper.cfg.


1
2018-03-29 06:41