Câu hỏi Khó chịu nhấp nháy trong 16.04 LTS - Chrome


Tôi đã nâng cấp từ 4.4.0 lên 4.4.8 và sau đó 4.5.2 trên Ubuntu 16.04 LTS 64-bit, và nó vẫn đang xảy ra.

Tại 4.5.2 nó thậm chí còn thường xuyên hơn, và chủ yếu là trong Chrome (chưa thử firefox hoặc opera). Mỗi khi tôi mở một trang web mới. Bất kỳ cách nào để sửa lỗi đó, hoặc nó là một lỗi?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Chúc mừng.


197
2018-05-03 06:31


gốc


Cùng một điều tôi trải nghiệm trên Ubuntu 14.04.4 - Billal Begueradj
Tôi cũng phải đối mặt với cùng một vấn đề, đặc biệt trong khi sử dụng facebook. Điều đó quá khó chịu. - sgiri
Thử --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers   một số thông tin bổ sung ở đây: productforums.google.com/forum/#!topic/chrome/… - Postadelmaga
Nhân viên Google ở ​​đây. Lỗi này đang được theo dõi trong trình theo dõi vấn đề Chromium tại # 606152 - Nhấp nháy trên Intel với tải lên một bản sao. - Dan Dascalescu
Tôi chuyển sang ngăn xếp HWE (kernel 4.8 và X-7.7). Nó ngừng rung. Có một số vấn đề với i915 (Intel HD Graphics Driver) trong kernel 4.4 series. - Manoj Sawai


Các câu trả lời:


Sau một số nghiên cứu, tôi đã tìm ra giải pháp cho vấn đề này. Nó đang làm việc cho tôi bây giờ.

Tôi đã tắt tính năng tăng tốc phần cứng cho trình duyệt của mình từ

Settings > Advance Settings > System > uncheck the hardware acceleration

Hy vọng điều này hoạt động trên máy của bạn.


tôi đang dùng google-chrome-stable Version 50.0.2661.94 (64-bit) trên Ubuntu 16.04

-----CHỈNH SỬA----

Nếu bạn gặp phải sự chậm trễ di chuyển và xé màn hình. Làm theo đề xuất của Amos Folarin trong nhận xét dưới đây:

Đi đến: chrome://flags/#smooth-scrolling và kích hoạt nó.


186
2018-05-05 17:54



Tôi đã thử điều đó, khắc phục sự cố nhưng làm cho độ trễ cuộn và màn hình của tôi bị rách. - Mookey
Điều này thực sự không nên được chấp nhận, vì nó không phải là một giải pháp, nó chắc chắn là một công việc xung quanh. - theV0ID
Điều này không ảnh hưởng đến việc nhấp nháy cho tôi. - DavidJ
Giải pháp này làm việc cho XPS13 9343 của tôi, nhấp nháy chắc chắn dừng lại hoặc không đáng chú ý. Tôi cũng đã thử giải pháp khác được đề xuất ở đây thiết lập chrome: // flags / # enable-gpu-rasterization thành 'Force-enabled for all layers' nhưng điều này không hiệu quả, chỉ việc vô hiệu hóa tăng tốc phần cứng trong chrome dường như hoạt động. Nhưng đồng ý với @ theV0ID rằng anh ấy không phải là ý tưởng. - Amos Folarin
Hãy thử bật chrome: // flags / # smooth-scrolling để cuộn mượt mà. Tôi đang sử dụng XPS13 + Ubuntu16.04 hoạt động tốt với tùy chọn tăng tốc phần cứng không được chọn - Amos Folarin


Tôi đã có cùng một vấn đề, thiết lập rasterization GPU để 'Force-enabled cho tất cả các lớp' có vẻ là cuối cùng làm việc:

Chrome Flags: GPU rasterization


158
2017-08-08 07:52



liên kết nhanh: chrome: // flags / # enable-gpu-rasterization - JohannesNE
cũng đã làm việc cho tôi. - Sufiyan Ghori
Nó ngừng hoạt động, nhấp nháy trở lại, tôi nghĩ sau khi nâng cấp lên Chrome phiên bản 53.0.2785.92 (64 bit) - Omid
Điều này làm giảm đáng kể nhấp nháy, nhưng nó vẫn còn trong Google Inbox, ví dụ (hiện tại là nơi duy nhất tôi thấy nó). - TiGR
Hoạt động, nhưng bây giờ chỉ có góc trên bên trái của một số hình ảnh đang được hiển thị. Tôi đã làm gì với chrome: // flags / # ignore-gpu-blacklist - Jasny - Arnold Daniels


Mở một thiết bị đầu cuối và nhập lệnh này:

sudo nano /usr/share/applications/chromium-browser.desktop

và cuộn xuống cho đến khi bạn đến được dòng này:

Exec= chromium-browser

Sau đó, thêm hai tham số này

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Nhấn Ctrl + O để lưu và Ctrl + X để thoát.

Sau đó, nhập lệnh này:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

và thêm những dòng này

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Nhấn Ctrl + O rồi nhấn Ctrl + X.

Mở Chromium và ghi vào thanh địa chỉ: chrome://flags/ và vào.

  • Bật-zero-copy
  • Bật danh sách hiển thị phần mềm ghi đè
  • Bật Canvas danh sách 2D hiển thị

Cuối cùng mở cài đặt chrome và nhấp vào:

  • Sử dụng tăng tốc phần cứng khi khả dụng

38
2017-07-27 08:10



Làm việc trên CPU Dell XPS 15 95050 Intel® Core i7-6700HQ của tôi @ 2.60GHz Đồ họa HD Intel® 530 (Skylake GT2). - Prydie
Trong trường hợp của tôi (sau khi thử nhiều giải pháp), tôi chỉ cần kích hoạt những cờ mà bạn đã đề cập (zero-copy, Override Software Rendering List, Display 2D List Canvas) và dường như đã sửa nó (trên Intel HD Graphics). - Nahuel
Hai dòng lệnh chuyển mạch (vô hiệu hóa cách giải quyết / cho phép bộ đệm bộ nhớ gpu tự nhiên) dường như không hoạt động nữa, nhưng tạo 20-intel.conf tập tin làm việc cho tôi! Cũng cho phép rasterization gpu (không chắc chắn nếu nó là quan trọng). - terabaud
Giải pháp làm việc duy nhất cho tôi. Cảm ơn - Darkside
Chỉ cần thêm 20-intel.conf đã làm việc cho tôi - không phải làm gì khác. - Vadi


Tôi đã sửa nó như sau:

sudo apt-get purge xserver-xorg-video-intel

sau đó khởi động lại. Điều này là do trình điều khiển Intel di chuyển đến chế độ. Để biết thêm thông tin, xem nhận xét này trong chuỗi lỗi Chromium.


37
2017-08-19 14:25



Tôi đã đi các tuyến cờ chrome và sau đó đi tuyến đường này thay vào đó và thiết lập lại các cờ để mặc định và thanh lọc các công cụ intel. Càng xa càng tốt. - Sethen
cảm ơn. Tôi có một NUC của Intel mới vài tuổi và đã trải qua một vài cập nhật. It's on 16.04.2 nhưng đề nghị của bạn đã tìm thấy các gói để thanh trừng. Nó không còn nhấp nháy (video HDMI của tôi đã nhấp nháy và tắt ở khoảng 1 hoặc 2 Hz sau một số cập nhật gần đây; Tôi nghĩ rằng nó đã phát triển một lỗi phần cứng sau 8 năm phục vụ). - Tim Richardson
Câu trả lời này nên cao hơn rất nhiều! - Galgalesh
Đây chính là nó? Nó hoạt động hoàn hảo !!! Câu trả lời hoàn toàn bị đánh giá thấp. Cảm ơn bạn rất nhiều! - uloco
Cảm ơn! Điều đó đã khắc phục vấn đề cho tôi. Câu trả lời của bạn phải cao hơn một vài điểm. - Anthony D.


Không ai trong số những câu trả lời này dường như giúp tôi. Những gì tôi đã kết thúc có vẻ đã sửa nó (Tham chiếu của tôi là trang này http://www.bang-olufsen.com/ mà flickered như CRAZY và bây giờ nó hoạt động trơn tru) là:

1. Điều hướng đến chrome://gpu/. Đây là những gì nó cho thấy:

enter image description here

2.- Tôi đã cố gắng sửa chữa từng vấn đề. Trong trường hợp của tôi, cho phép các cờ này sửa một số trong số chúng: GPU rasterization, Override software rendering list. Sau đó, nó cho thấy như thế này:

enter image description here

3.- Tôi đã chỉnh sửa trình khởi chạy trên máy tính để bàn và thêm thông số --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers.

4.- Sau đó, không phát hiện thêm vấn đề nào, mọi thứ hiển thị là "phần cứng được tăng tốc" và, quan trọng hơn, không còn nhấp nháy nữa:

enter image description here

Nếu bạn thêm tham số vào trình khởi chạy trước, danh sách các sự cố sẽ ngắn hơn và có thể sẽ dễ dàng hơn để tìm ra cờ nào sẽ giúp bạn giải quyết các vấn đề bạn đã bỏ sót.


25
2017-09-14 12:29



Đây là một tài liệu tham khảo tốt. Tôi đã sử dụng nó để giải quyết vấn đề của tôi với firefox, nơi nó được giải quyết đơn giản bằng cách bỏ chọn hộp "Sử dụng tăng tốc phần cứng" trong cài đặt nâng cao. - Bach
Điều này làm giảm sự nhấp nháy của tôi, nhưng nó vẫn xảy ra thường xuyên ... - addison


Với phiên bản Chrome 51.0.2704.103 (64 bit) cờ

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

không làm việc nữa.

Cách tốt nhất chúng ta có thể làm là quay lại Chrome 50 (Phiên bản 50.0.2661.86 (64-bit)), đây là hướng dẫn cách bạn có thể quay lại: làm cách nào để hạ cấp google chrome? 

Quan trọng là chúng tôi gây áp lực lên Google để khắc phục sự cố này, bỏ phiếu cho lỗi trong Chromium và trên trang sản phẩm của Google:

https://bugs.chromium.org/p/chromium/issues/detail?id=606152

https://productforums.google.com/forum/#!topic/chrome/CtKF2BiskT8;context-place=forum/chrome


7
2018-06-19 08:02



Không làm việc cho tôi. - ComBin
@ComBin: bạn đã thử bước trở lại v50 và sử dụng cờ chưa? Tuy nhiên, theo liên kết đến lỗi crom có ​​rất nhiều đề xuất giải pháp khác nhau để làm điều này để làm việc với phiên bản chrome /ium hiện tại. - user157697
tôi không muốn v50, cảm ơn. Tôi được tìm thấy cách tốt nhất để sửa chữa nó, xem câu trả lời của tôi dưới đây. - ComBin
AHa, trong lỗi crom, kẻ có nghĩa là điều này sẽ có vấn đề hiệu suất lớn. Tuy nhiên tôi sẽ thử một số gợi ý từ các lỗi crom khi tôi có thời gian, theo như tôi hiểu Chromium chỉ là triệu chứng không phải là nguyên nhân. Tôi sẽ giữ cho bạn cập nhật nếu tôi tìm thấy một cái gì đó tốt hơn / khác. Chúc mừng. - user157697


chrome://flags/ > GPU rasterization > Enable,

Điều này cuối cùng đã làm việc cho tôi! Tìm thấy nó ở dưới cùng của mẫu Google này! https://productforums.google.com/forum/#!msg/chrome/CtKF2BiskT8/dLXKfU2XAQAJ


5
2017-10-16 20:44