Câu hỏi Ngăn xếp kích hoạt LTS trên Trusty có các khoản tiền chưa được đáp ứng


Tôi có Ubuntu 14.04 (kernel 3.19.0-49) và tôi muốn cài đặt LTS Enablement Stack mới nhất để truy cập kernel 4+.

Theo wiki, Tôi cần phải làm

$ sudo apt-get install --install-recommends linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily 


Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 xserver-xorg-lts-wily : Recommends: libgl1-mesa-glx-lts-wily but it is not going to be installed
                         Recommends: libegl1-mesa-drivers-lts-wily but it is not installable
                         Recommends: libgles2-mesa-lts-wily but it is not going to be installed
                         Recommends: libgles1-mesa-lts-wily but it is not going to be installed
                         Conflicts: libgl1-mesa-glx (>= 0~)
                         Conflicts: libglapi-mesa (>= 0~)
                         Conflicts: libgles2-mesa (>= 0~)
E: Unable to correct problems, you have held broken packages.

nhưng tôi đang trải qua những sự phụ thuộc chưa được đáp ứng.

Tại sao? Tôi nên làm gì?

Cảm ơn bạn.


CHỈNH SỬA:

Thật không may, tôi không thể cài đặt các gói được đề xuất một mình.

$ sudo apt-get install libgl1-mesa-glx-lts-wily
[...]
The following packages have unmet dependencies:

 libgl1-mesa-glx-lts-wily : Depends: libglapi-mesa-lts-wily (= 11.0.2-1ubuntu4~trusty1) but it is not going to be installed
Depends: libgl1-mesa-dri-lts-wily (>= 7.2) but it is not going to be installed

Và nếu tôi cố gắng cài đặt

$ sudo apt-get install libglapi-mesa-lts-wily

The following packages have unmet dependencies:
 libglapi-mesa-lts-wily : Conflicts: libglapi-mesa
                          Conflicts: libglapi-mesa:i386

EDIT-2:

Thật không may, với LTE HWE cài đặt hệ thống không khởi động. Nó bị treo khi khởi động và không tiến tới màn hình đăng nhập.

Tôi "giải quyết" bằng cách cài đặt lại Ubuntu 14.04.4 từ đầu.


5
2018-02-22 13:39


gốc




Các câu trả lời:


Lệnh đúng là

sudo apt-get install linux-generic-lts-wily xserver-xorg-lts-wily libgl1-mesa-glx-lts-wily libglapi-mesa-lts-wily libwayland-egl1-mesa-lts-wily libgl1-mesa-glx-lts-wily:i386 libglapi-mesa-lts-wily:i386

Wiki "chính thức" đó luôn sai.

Và cũng lưu ý rằng bạn KHÔNG phải nâng cấp xserver-xorg nếu bạn muốn hạt nhân 4.2. Bạn có thể nâng cấp hạt nhân chỉ bằng

sudo apt-get install linux-generic-lts-wily

1
2018-02-22 16:09



Cảm ơn sự giúp đỡ của bạn. Tuy nhiên, thật không may, với việc cài đặt LTE HWE, hệ thống không khởi động. Nó bị treo khi khởi động và không tiến tới màn hình đăng nhập. Tôi "giải quyết" bằng cách cài đặt lại Ubuntu 14.04.4 từ đầu. - Claudio
Làm việc hoàn hảo cho tôi khi tôi chỉ có một màn hình trống sau khi cài đặt những gì wiki nói! Tôi không còn tin tưởng vào wiki nữa! - Daniyal


Đầu tiên, (hãy cẩn thận ở đây) xóa các gói vi phạm và sau đó chạy tiến trình cài đặt:

sudo apt-get purge libgl1-mesa-glx libgl1-mesa-glx:i386 libglapi-mesa libgles2-mesa libglapi-mesa:i386 libgles2-mesa:i386 
sudo apt-get install --install-recommends libgl1-mesa-glx-lts-wily libegl1-mesa-drivers-lts-wily libgles2-mesa-lts-wily linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily libgles1-mesa-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily

Nếu bạn cũng cần phiên bản i386, hãy chạy phiên bản này:

sudo apt-get install libgl1-mesa-glx-lts-wily:i386 libegl1-mesa-drivers-lts-wily:i386 libgles2-mesa-lts-wily:i386 linux-generic-lts-wily:i386 xserver-xorg-core-lts-wily:i386 xserver-xorg-lts-wily:i386 libgles1-mesa-lts-wily:i386 xserver-xorg-video-all-lts-wily:i386 xserver-xorg-input-all-lts-wily:i386 libwayland-egl1-mesa-lts-wily

hoặc chỉ cần cài đặt mà không có đề xuất:

sudo apt-get install linux-generic-lts-wily xserver-xorg-core-lts-wily xserver-xorg-lts-wily xserver-xorg-video-all-lts-wily xserver-xorg-input-all-lts-wily libwayland-egl1-mesa-lts-wily

0
2018-02-22 13:48



Tôi đã chỉnh sửa câu trả lời ban đầu của mình. Cảm ơn bạn. - Claudio
@Claudio Tôi đã cập nhật câu trả lời. Những gì tôi có nghĩa là "cẩn thận" là, chú ý đến những gì sẽ được gỡ bỏ cài đặt và không chấp nhận những thay đổi nếu nó muốn gỡ bỏ cài đặt một bó toàn bộ các công cụ khác mà bạn muốn giữ. Nếu danh sách các gói để gỡ cài đặt ngắn, hãy lưu ý danh sách và chấp nhận các thay đổi. - mchid
Cảm ơn sự giúp đỡ của bạn. Tuy nhiên, thật không may, với việc cài đặt LTE HWE, hệ thống không khởi động. Nó bị treo khi khởi động và không tiến tới màn hình đăng nhập. Tôi "giải quyết" bằng cách cài đặt lại Ubuntu 14.04.4 từ đầu. - Claudio
@Claudio gì, bạn đã cài đặt nvidia từ nguồn hay cái gì? - mchid


Đã có cùng một vấn đề. Được giải quyết bằng cách xóa libgles2-mesa-lts-utopic và libglapi-mesa-lts-utopic trước tiên:

sudo apt-get purge libgles2-mesa-lts-utopic libglapi-mesa-lts-utopic

Và sau đó cài đặt bằng lệnh wiki.


0
2018-02-24 11:26