Câu hỏi Cách chính xác để cài đặt độc quyền ATI Catalyst Video Drivers (fglrx) trực tiếp từ AMD là gì?


Tôi đang lên kế hoạch thực hiện cài đặt Ubuntu mới và muốn biết cách cài đặt Trình điều khiển Video ATI Catalyst chính xác là gì?


Có nhiều câu trả lời hợp lệ cho câu hỏi này trải rộng trên một số phiên bản của Ubuntu. Để thuận tiện cho bạn, chỉ mục của mỗi bên dưới:


161
2018-04-22 19:51


gốc


Chăm sóc để cập nhật điều này cho 14.10? Nhiều nghĩa vụ! - Torben Gundtofte-Bruun
và cho 16.04? ... - Boris


Các câu trả lời:


14.04 / 14.10 - Cài đặt trình điều khiển từ trang web AMD

Đầu tiên, đảm bảo hệ điều hành Ubuntu của bạn được cập nhật. Để kiểm tra điều này, hãy nhấp vào biểu tượng quyền lực ở góc trên cùng bên phải. Từ trình đơn, chọn 'Giới thiệu về máy tính này'. Bây giờ hãy kiểm tra xem có nút 'Cài đặt cập nhật' không (nó có thể xuất hiện sau vài giây sau nút 'Kiểm tra cập nhật') có thể được sử dụng để cập nhật như được hiển thị bên dưới. Nếu không, hệ thống của bạn được cập nhật.


(Đầu tiên bạn có thể thấy điều này) enter image description here

(Thì đây) enter image description here

(Sau khi nhấn 'Cài đặt Cập nhật', bạn sẽ thấy điều này) enter image description here


Bạn cũng có thể sử dụng lệnh terminal như hình bên dưới để cập nhật:

sudo apt-get update && sudo apt-get upgrade
  • Sau đó đi đến Trang web AMD, chọn trình điều khiển theo cách thủ công và tải xuống. Nếu bạn không chắc chắn trình điều khiển nào sẽ cài đặt thì bạn có thể cài đặt phần mềm phát hiện trình điều khiển '' trong hệ điều hành Windows của bạn và xem trình điều khiển mà bạn nên cài đặt.

  • Kiểm tra ghi chú phát hành và ghi chú của trình cài đặt của bất kỳ trình điều khiển nào bạn sẽ cài đặt mà không bị lỗi. Xem nếu bạn Hệ điều hành đáp ứng tất cả các yêu cầu hệ thống được đề cập trong ghi chú phát hành.

  • Sau đó làm theo các bước trong ghi chú trình cài đặt để cài đặt trình điều khiển của bạn.

CHÚ THÍCH:

1: Nếu bạn cài đặt trình điều khiển sai (hoặc mắc lỗi khác khi cài đặt trình điều khiển), Unity có thể gặp sự cố hoặc bạn có thể gặp sự cố "Hệ thống đang chạy ở chế độ đồ họa thấp" (hoặc một số vấn đề khác). Dù vấn đề là gì, trước tiên bạn phải xóa trình điều khiển bạn đã cài đặt. Đối với điều này, bắt đầu một phiên tty bằng cách nhấn CTRL+ALT+F1. Sau đó, sử dụng lệnh này:

sudo aticonfig --uninstall

Điều này sẽ xóa trình điều khiển của bạn. Nếu không tham khảo điều này . Bây giờ sử dụng lệnh:

sudo shutdown -r now

để khởi động lại hệ thống của bạn. Điều này sẽ giúp bạn quay lại sự thống nhất mà không gặp vấn đề gì. Bây giờ bạn lại có thể vào trang AMD, có được trình điều khiển được hỗ trợ và cài đặt.

Nếu điều này không giải quyết được vấn đề của bạn đề cập đến những câu hỏi này có thể hữu ích:

2: Ngoài ra nếu bạn không biết liệu HĐH của bạn có đáp ứng các yêu cầu hệ thống của trình điều khiển được đề cập trong ghi chú phát hành của nó hay không, thì các lệnh sau có thể giúp:

  1. uname -a : sẽ cho bạn biết về hạt nhân của bạn
  2. Xorg -version  : sẽ cho bạn biết về Xorg của bạn
  3. ldd --version  : sẽ cho bạn biết glibc của bạn

Ngoài ra nó không phải là cần thiết mà hệ điều hành của bạn cần phải xác định trong các ghi chú phát hành. Chỉ cần xem nếu bạn đáp ứng các yêu cầu hệ thống và nếu card đồ họa của bạn được đề cập trong ghi chú phát hành.

3: Đảm bảo bạn cập nhật hệ điều hành của mình trước khi cài đặt trình điều khiển đồ họa như đã nêu ở trên. Trong khi hệ điều hành của bạn có thể hỗ trợ trình điều khiển của bạn trước khi cập nhật, sau khi cập nhật hệ điều hành của bạn có thể không.

4: Cũng đừng ngạc nhiên nếu trình cài đặt trình điều khiển của bạn xuất hiện như thế này (không có bất kỳ văn bản nào):

enter image description here

Trong trường hợp này, hãy xem ghi chú của trình cài đặt và với sự trợ giúp của các ảnh chụp màn hình được cung cấp tại đó, hãy cài đặt trình điều khiển của bạn.

P .:

Theo quan điểm khiêm tốn của tôi, các trình điều khiển nguồn mở mặc định phục vụ tất cả các nhu cầu bình thường của máy tính. Vì vậy, cài đặt các trình điều khiển độc quyền chỉ khi bạn thực sự cần nó (như nếu bạn là một game thủ 'techy' hoặc một cái gì đó). Ngoài ra, nếu bạn đang cố cài đặt trình điều khiển độc quyền của mình chỉ để có được độ phân giải màn hình tối đa thì bạn có thể tham khảo điều này câu trả lời.


31
2018-03-18 08:13



Một câu trả lời cực kỳ hoàn chỉnh! - Charles Green
Bạn nói "Nếu bạn không chắc chắn trình điều khiển để cài đặt", nhưng tôi dường như không có nhiều sự lựa chọn trong trình điều khiển. Khi tôi nhấp vào "Linux (32-bit & 64-bit)", trình điều khiển duy nhất được cung cấp là trình điều khiển độc quyền tương tự được cung cấp thông qua hộp thoại "Trình điều khiển bổ sung" và những người không hoạt động đúng cách - Peter Raeves
Yep nó chắc chắn là một vấn đề với amd, trình điều khiển beta chưa được phát hành của họ đã lỗi thời - Nick Bailuc
Thật không may, có vẻ như không thể sử dụng Ubuntu 14.04 với một số card đồ họa ATI (ví dụ: thẻ ATI RadeonHD 2x00 - 4xx0) từ wiki này. Giải pháp là sử dụng Ubuntu 12.04 cho các thẻ này. - Boris
Câu trả lời ở đây đã giúp tôi: askubuntu.com/a/568524/178596 - Wilf


Các hướng dẫn sau đây giải thích cách cài đặt trình điều khiển video ATI Catalyst mới nhất của Ubuntu 12.04 LTS (Chính xác tê tê).

chú thích

AMD đã phát hành Chất xúc tác 12.8 trình điều khiển cho các hệ thống Linux trong   Tháng 8 mang đến một số cải tiến và sửa lỗi. Trình điều khiển này dựa trên bản phát hành fglrx 8.982, và nó cải thiện hỗ trợ cho Ubuntu 12.04 LTS.


Để cập nhật thông tin trình điều khiển mới nhất, hãy luôn tham khảo Trang web chính thức của AMD khi cập nhật được xuất bản khá thường xuyên.

Cài đặt trình điều khiển AMD / ATI Catalyst cho 12.04 LTS

Đã thử nghiệm: v12.4, v12.6, v12.8


Thông tin quan trọng và chuẩn bị

Chỉ sử dụng các hướng dẫn này nếu bạn đã chọn KHÔNG PHẢI để sử dụng các tệp nhị phân Ubuntu chính thức.

  • Nếu bạn muốn sử dụng các tệp nhị phân Ubuntu chính thức hoặc muốn cài đặt trình điều khiển video ATI Catalyst mới nhất cho các phiên bản trước của Ubuntu, điều hướng đến câu trả lời của câu hỏi này và làm theo hướng dẫn.

Trước khi quyết định, hãy kiểm tra xem Ubuntu có hỗ trợ thẻ video của bạn không đây.

  • Nếu bạn hiện đang sử dụng các tệp nhị phân Ubuntu chính thức và muốn cài đặt trình điều khiển video ATI Catalyst mới nhất có điều kiện tiên quyết để thanh lọc một số tệp. Trước khi tiếp tục với các hướng dẫn này. Bạn có thể Bỏ qua bước để thanh trừng nếu bạn có một bản cài đặt mới của Ubuntu 12.04.

Loại bỏ (dọn dẹp) trình điều khiển hiện tại

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Cài đặt những phụ thuộc này

Bạn cần phải cài đặt một số phụ thuộc vào hệ thống của bạn, thực hiện điều này bằng cách chạy chúng trong Terminal:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases

Chỉ dành cho 64 bit

sudo apt-get install ia32-libs-multiarch i386 lib32gcc1 libc6-i386

Cài đặt trình điều khiển ATI / AMD mới nhất

Tải xuống trình điều khiển thích hợp cho máy của bạn từ trang web AMD / ATI và sau đó nhập thông tin sau vào thiết bị đầu cuối (nhớ điều hướng tới nơi bạn trích xuất trình điều khiển trước và đảm bảo không có tệp .run nào khác tồn tại trong thư mục đó):

sudo sh *.run --buildpkg Ubuntu/precise

Nếu nó được yêu cầu, một cửa sổ quản lý gói sẽ mở và cài đặt một số phụ thuộc và sau một thời gian tạo ra bốn gói .deb sau đây:

fglrx_8.961-0ubuntu1_amd64.deb
fglrx-amdcccle_8.961-0ubuntu1_amd64.deb
fglrx-dev_8.961-0ubuntu1_amd64.deb

Lưu ý: Nó cũng sẽ tạo ra một tập tin gọi là fglrx-installer_8.961-0ubuntu1_amd64.changes. Nếu bạn muốn bạn có thể đọc tập tin này để biết những thay đổi đã bị ảnh hưởng thông qua AMD / ATI Catalyst và thông tin liên quan.

Để cài đặt các tệp .deb đã tạo, hãy nhập:

sudo dpkg -i *.deb

Lưu ý: Trong trường hợp bất kỳ gói nào bị hỏng, mở Synaptic Package Manager và vào Edit -> Fix Broken Packages. Trong trường hợp bạn mới dùng Ubuntu, bị hỏng ở đây có nghĩa là một số gói phụ thuộc chưa được cài đặt. Khi bạn phân loại vấn đề như được chỉ ra ở trên thông qua Trình quản lý gói Synaptic, vấn đề của các gói bị hỏng sẽ được giải quyết.

Tiếp tục cài đặt, gõ:

sudo aticonfig --initial

Trước khi khởi động lại máy tính của bạn: Nếu bạn đang sử dụng phiên bản beta, bạn có thể muốn loại bỏ hình mờ "Thử nghiệm" của AMD. Nếu không, hãy bỏ qua khối hướng dẫn tiếp theo.

Phiên bản beta: Loại bỏ hình mờ "Thử nghiệm" của AMD

Chỉnh sửa tệp chữ ký ATI qua "nano" hoặc "gedit":

sudo nano /etc/ati/signature

HOẶC LÀ

sudo gedit /etc/ati/signature

Bằng cách thay thế dòng "UNSIGNED" bằng mã sau:

9777c589791007f4aeef06c922ad54a2:ae59f5b9572136d99fdd36f0109d358fa643f2bd4a2644d9efbb4fe91a9f6590a145:f612f0b01f2565cd9bd834f8119b309bae11a1ed4a2661c49fdf3fad11986cc4f641f1ba1f2265909a8e34ff1699309bf211a7eb4d7662cd9f8e3faf14986d92f646f1bc

Đảm bảo lưu trước / đóng tệp.

Điều đó sẽ loại bỏ các watermark "Thử nghiệm" AMD (mà bây giờ bạn sẽ không bao giờ   xem) từ dưới cùng bên phải của màn hình khi bạn khởi động lại   (nguồn).

Bây giờ hãy tiếp tục và khởi động lại máy tính của bạn.

Nếu tất cả là đúng, trình điều khiển fglrx tương ứng với AMD / ATI Catalyst sẽ được cài đặt và hoạt động trên hệ thống của bạn. Để xác nhận các trình điều khiển đang làm việc mở một thiết bị đầu cuối và gõ:

fglrxinfo

Bạn sẽ nhận được một đầu ra tương tự như sau:

display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: ATI Radeon HD 4300/4500 Series
OpenGL version string: 3.3.11631 Compatibility Profile Context

Lưu ý: Nếu bạn thấy bất kỳ đề cập đến MESA trong đầu ra, các trình điều khiển fglrx chưa được cài đặt chính xác. Xem phần khắc phục sự cố để biết thêm chi tiết

Bạn có thể thực hiện thay đổi cấu hình thông qua Trung tâm điều khiển Catalyst của AMD / ATI. Nó có thể được tìm thấy trong menu Ứng dụng của bạn hoặc bạn có thể khởi chạy nó thông qua một thiết bị đầu cuối như thế này:

sudo amdcccle

LƯU Ý QUAN TRỌNG:

Lưu ý rằng khi bạn cài đặt fglrx theo cách thủ công, điều này có thể phá vỡ hệ thống của bạn một cách tinh tế, vì hệ thống đóng gói không được biết về các thay đổi của bạn.

Các Bệ phóng các nhà phát triển nhận được nhiều báo cáo lỗi từ những người dùng thực hiện việc này và sau đó phát hiện ra sau một vài nâng cấp mà hệ thống của họ bắt đầu hoạt động lạ vì những tàn dư fglrx đó.


107
2018-05-01 09:52



Chỉ cần bạn biết, dòng sudo sh amd-driver-installer-*.run --buildpkg Ubuntu/precise có thể được thay thế bằng sudo sh ./*.run --buildpkg Ubuntu/precise - Adam F
Trên Ubuntu 12.10 với Beta Driver 13.3, sửa dấu vân / etc / ati / chữ ký chỉ có đã làm việc khi mã được nhập KHÔNG CÓ một dòng mới ở cuối và KHÔNG có khoảng trống cuối. Khi tôi sao chép và dán, tôi vô tình nắm lấy một số khoảng trắng và nó không hoạt động lúc đầu. - Toby J
THÊM "không cần cho các hệ thống 32 bit" GIỚI THIỆU "sudo apt-get cài đặt ia32-libs" BECAUSE LINK: "askubuntu.com/questions/143904/…; NHẬN XÉT THÀNH CÔNG. LỐI THOÁT? [Y / n] - yinon
Nó làm việc tuyệt vời! - Alejandro Sazo
Tôi đã thử sử dụng điều này để cài đặt trình điều khiển mới nhất (13.1) và gặp lỗi "BadRequest" khi thử nghiệm glxinfo(chi tiết tại đây notepad.cc/maugixu11). Phần phần khắc phục sự cố ở đâu? - phunehehe


Cài đặt trình điều khiển Catalyst ATI cho 12.10

Cập nhật quan trọng (ngày 22 tháng 10 năm 2012)

Không thể sử dụng phiên bản trình điều khiển AMD Catalyst độc quyền mới nhất 12.9   với Ubuntu 12.10 Nếu bạn có một loạt thẻ AMD Radeon HD 2xxx-4xxx.

Trình điều khiển cho các thẻ này hiện có sẵn trong một chi nhánh riêng được gọi là   chuỗi kế thừa. Rất tiếc, các trình điều khiển cũ này (phiên bản 12.6) có   chưa được cập nhật để làm việc với Ubuntu 12.10. Ubuntu 12.10 đi kèm với   xorg 1,13 trong khi các trình điều khiển này có hỗ trợ cho xorg 1,12 cũ hơn. Do đó, nếu   bạn muốn cài đặt các trình điều khiển này trong Ubuntu 12.10, bạn phải   hạ cấp xuống xorg 1,12.

Nguồn và tải xuống Trình điều khiển cũ ở đây (nếu ghi chú ở trên áp dụng cho bạn


HƯỚNG DẪN

Gỡ cài đặt trước hết trình điều khiển AMD hiện tại bằng hai lệnh sau:

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev* xorg-driver-fglrx

Chú thích: Bạn sẽ cần phải cài đặt các trình điều khiển (theo các hướng dẫn dưới đây) nhưng trước tiên hãy thêm cùng các phụ thuộc được mô tả trong câu trả lời ở trên cho 12.04LTS.

Bắt đầu cài đặt ATI Catalyst v # với các lệnh này trong Ubuntu 12.10 hoặc cũ hơn:

cd /tmp && wget -O amd-driver-12-6-x86_64.run http://www2.ati.com/drivers/linux/amd-driver-installer-12-6-x86.x86_64.run
chmod +x amd-driver-12-6-x86_64.run
sudo sh amd-driver-12-6-x86_64.run

Sau đó làm theo hướng dẫn thiết lập:

Chạy lệnh sau để kết thúc cài đặt:

sudo aticonfig --initial -f

Sau đó khởi động lại hệ thống của bạn:

sudo reboot

Đó là nó!


44
2018-04-27 17:48



Trình điều khiển ATI 12.10 có hoạt động không? - jrg♦
@ jrg Tôi đã duy trì Q & A này và cập nhật liên quan đến những gì Ive đã kiểm tra. Tôi chưa thử nghiệm 12,10 ATI nhưng câu trả lời là tôi không biết. Tôi có một số những thứ khác đang diễn ra và sẽ không được vòng này một thời gian (tôi tin rằng 12,11 Trình điều khiển được avaialble cũng) - stephenmyall
Với card hd 5670, tôi phải bỏ qua trình điều khiển 12.10 hoàn toàn và cài đặt bản beta 12.11. Hướng dẫn tại đây askubuntu.com/a/206025/55564. Với Quantal Quetzal trình điều khiển ati 12.10 không tương thích với sự thống nhất và sau khi compiz đăng nhập sẽ sụp đổ. - thelastshadow
Trình điều khiển AMD bây giờ dành cho Linux là ... phiên bản 13.1 liên kết. Tôi sẽ dùng thử và sau đó cập nhật phần Hỏi & đáp này. - Crimbo
Tôi đã cập nhật phần Hỏi & đáp này ... chờ đợi @stephen để đẩy các thay đổi. - Crimbo


Cài đặt Trình điều khiển Catalyst ATI cho 13.04

Những hướng dẫn này sẽ cài đặt Catalyst v13.4, để xem trình điều khiển mới nhất có sẵn truy cập vào Trang web chính thức của AMD

Hướng dẫn

Kiểm tra thẻ của bạn

Chỉ các thẻ RadeonHD mới được trình điều khiển Catalyst hỗ trợ.

Để biết loại thẻ nào được cài đặt trong hệ thống, hãy nhập lệnh sau vào terminal:

lspci | grep VGA

Nó có thể cho bạn thấy card đồ họa của bạn.

Trước khi tiếp tục vui lòng đọc đầu tiên! Thẻ Radeon nào không còn được hỗ trợ bởi Chất xúc tác ATI:

  • Thẻ không còn có thể sử dụng các trình điều khiển AMD Catalyst và được giới hạn cho các trình điều khiển nguồn mở:

    ATI Radeon 9500-9800, Xpress200-1250, 690G, 740G, X300-X2500, Mobility RadeonHD 2300

  • Thẻ không hoạt động với AMD Catalyst trong phiên bản Xserver mới hơn v1.13 và Linux Kernel mới hơn v3.5:

    Thẻ ATI RadeonHD 2x00 - 4xx0

    Các thẻ này có thể sử dụng trình điều khiển Catalyst Legacy, nhưng chỉ khi bạn hạ cấp phiên bản Xserver của mình. Điều này có thể được thực hiện dễ dàng bằng cách làm theo các hướng dẫn được đưa ra tại Bệ phóng. PPA này hạ cấp Xserver và cài đặt một phiên bản vá của fglrx hỗ trợ phiên bản kernel 3.5.

Loại bỏ (dọn dẹp) trình điều khiển hiện tại

sudo sh /usr/share/ati/fglrx-uninstall.sh
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

Cài đặt phụ thuộc

  • Đối với hệ thống 32 bit:

    sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases linux-headers-generic fakeroot libqtgui4
    
  • Đối với hệ thống 64 bit:

    sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases linux-headers-generic fakeroot libqtgui4 lib32gcc1
    

Tải xuống gói Catalyst

cd ~/
mkdir catalyst
cd catalyst/

Để có các trình điều khiển mới nhất được cài đặt kiểm tra nếu v13.4 là mới nhất được cung cấp trong Trang web AMD, nếu v13.4 không phải là mới nhất, bạn có thể muốn tải xuống trình điều khiển theo cách thủ công từ đó, giải nén tệp zip vào ~ / catalyst / folder và sau đó bỏ qua hai lệnh đầu tiên sau và thực thi thay thế cuối cùng tên gói bằng tên của một chiết xuất trong ~ / chất xúc tác / thư mục

wget http://www2.ati.com/drivers/linux/amd-catalyst-13.4-linux-x86.x86_64.zip
unzip amd-catalyst-13.4-linux-x86.x86_64.zip
chmod +x amd-catalyst-13.4-linux-x86.x86_64.run

Cài đặt trình điều khiển

Điều hướng đến gói được giải nén (~/catalyst/), hãy chắc chắn nó là duy nhất .run tệp trong thư mục đó và nhập vào lệnh sau

sudo sh *.run --buildpkg Ubuntu/raring

Một cửa sổ AMD Catalyst sẽ mở ra để triển khai các gói .deb đợi cho đến khi nó kết thúc và sau đó thực hiện lệnh này để tiếp tục:

sudo dpkg -i fglrx*.deb

Cấu hình

  • Cấu hình chung

    Điều này sẽ làm việc cho hầu hết mọi người

    sudo aticonfig --initial -f
    
  • Cấu hình tối thiểu

    Một tập tin /etc/X11/xorg.conf rất cơ bản có thể là những gì bạn cần nếu bạn có một thẻ mới không được hỗ trợ đầy đủ bởi aticonfig. Dưới đây là toàn bộ tập tin xorg.conf tối thiểu cho Radeon HD 6870:

    Section "Device"
     Identifier "ATI radeon 6870"
     Driver "fglrx"
    EndSection
    
  • Thẻ GPU X2 / Dual

    Chỉ sử dụng nếu bạn có thẻ X2 (ví dụ: 4870X2 hoặc 5970) !! Không sử dụng cho hai thẻ riêng biệt trong crossfire !!


32



Bạn đã thử nghiệm này chưa? Với mô hình gì? Kết quả của bạn là gì? - Lucio
Có, tôi sở hữu một Radeon HD 7970, Ubuntu 13.04 64-bit, hoạt động hoàn hảo, mặc dù tôi đã đọc về những người không loại bỏ (đã xóa) các trình điều khiển hiện có và gặp sự cố khi khởi động. Tôi sử dụng Blender cho mô hình 3D và mô phỏng, hiệu suất tăng lên khi xử lý thay đổi mặt dưới (tức là nhiều đa giác hơn trên hiện trường). - Rodrigo Martins
amdconfig và aticonfig là lệnh rất giống nhau, bạn có thể sử dụng một trong hai. Tôi thích sử dụng aticonfig bởi vì, không biết tại sao, một số hệ thống có thể trả về điều này: amdconfig: command not found vì vậy tốt hơn nên tiếp tục aticonfig, mặc dù sử dụng cái kia sẽ không tạo ra sự khác biệt nào. - Rodrigo Martins
@RodrigoMartins cảm ơn lời giải thích của bạn. Lời khuyên của tôi là gạch dưới hoặc in đậm đoạn về thẻ không được hỗ trợ. Có lẽ điều này nên là một phần của hướng dẫn, là điểm đầu tiên "kiểm tra xem thẻ của bạn có được hỗ trợ" với các lệnh sẵn sàng để lấy mẫu thẻ hay không. Tôi vừa mất 2 giờ trong cuộc đời và sau đó tôi đọc đoạn về thẻ không được hỗ trợ <facepalm>. Giải pháp với Tomasz Makarewicz PPA là tuyệt vời, hoạt động hoàn hảo (hạ cấp XServer) ... - s3m3n
Nếu tôi thay đổi sudo sh *.run --buildpkg Ubuntu/raring đến sudo sh *.run --buildpkg Ubuntu/saucy các hướng dẫn tương tự này có hoạt động với 13.10 không? - Chris Carter


Có một cách tiếp cận khác. Chúng tôi duy trì một PPA được gọi là x-cập nhật cung cấp các trình điều khiển cập nhật cho các phiên bản ổn định.

https://launchpad.net/~ubuntu-x-swat/+archive/x-updates?field.series_filter=precise

Đây thực sự là cách tốt nhất để cập nhật trình điều khiển kể từ: 

a) Cài đặt dễ dàng hơn rất nhiều (chỉ cần lật trên một ppa và nâng cấp),

b) nó sẽ không phá vỡ hệ thống của bạn khi bạn nâng cấp,

c) bạn vẫn có thể gửi báo cáo lỗi và mong đợi hỗ trợ từ Ubuntu.

Thật không may, như bạn thấy, chúng tôi không có -fglrx trong đó cho chính xác, và các phiên bản chúng tôi có cho các bản phát hành trong quá khứ là một chút ngày mình.

Điều này là do các nhân viên bảo trì chính thức như tôi có xu hướng lười biếng ... ahem bận rộn với bản phát hành và / hoặc sửa lỗi cho LTS, vì vậy không thường xuyên cập nhật PPA này. Nhưng, chúng tôi rất khuyến khích và ủng hộ các thành viên cộng đồng để giúp chúng tôi duy trì PPA này. Chúng tôi có các thủ tục tất cả các tài liệu đến mức độ đó là phần lớn nút nhấn; nếu bạn có thể hiểu và thực hiện các bước được mô tả trong các câu trả lời khác ở đây, và bạn biết cách sử dụng PPA, và có một hệ thống ATI bạn có thể kiểm tra các gói của mình, bạn đã có các kỹ năng cần thiết. Nó chỉ là vấn đề nhận biết bạn để chúng tôi có thể tin tưởng bạn. Chúng tôi sẽ rất vui khi được huấn luyện và cố vấn cho bạn, tất cả những gì bạn cần mang lại là sự quan tâm và tận tụy.

Tất nhiên, nếu bạn là chỉ có quan tâm đến việc cập nhật máy tính của riêng bạn, tất cả điều này có vẻ như rất nhiều nỗ lực. Tuy nhiên, nó chỉ yêu cầu một tình nguyện viên thực hiện nhiệm vụ này và sau đó nó đơn giản hóa cuộc sống cho tất cả mọi người. Kiểm tra xem có bao nhiêu lượt xem câu hỏi này đã nhận được cho đến nay - hơn 10.000. Vì vậy, một tình nguyện viên ở đây có thể tạo nên sự khác biệt to lớn.


8



Khi tôi cố gắng để thêm PPA, tôi nhận được điều này: Cannot access PPA (https://launchpad.net/api/1.0/~ubuntu-x-swat/+archive/x-update) to get PPA information, please check your internet connection. Tôi kết nối với Internet, tôi có thể đăng bình luận này chỉ vì tôi đã kết nối: P - Aman Alam
Liên kết đó đề cập đến Nvidia và không phải ATI?!? - fleamour
Tôi nhận được lỗi sau: sh: 0: Không thể mở /usr/share/ati/fglrx-uninstall.sh - James
Nếu nó cài đặt ok, bạn có thể bỏ qua lỗi đó. Tôi nghĩ rằng trình cài đặt sẽ kiểm tra để phát hiện các cài đặt trước đó. Nếu nó ngăn cản bạn cài đặt trình điều khiển, hãy gửi báo cáo lỗi. - Bryce