Câu hỏi Sự cố với đồ họa khi khởi động UBUNTU


  1. Tôi đã cài đặt UBUNTU tối thiểu 15.04 - KHÔNG có GUI và tôi KHÔNG muốn nó.
  2. Ubuntu này có 3.19.0-49-generic hạt nhân.
  3. Khi hệ thống khởi động với hạt nhân này lúc đầu, tôi có thể thấy các ký tự / chữ cái / số lạ - hoàn toàn không đọc được (xem phần đính kèm). Nhưng sau vài giây màn hình của tôi là màu đen và đẹp, màu trắng, các ký tự có thể đọc được hiển thị - vì vậy nó hoạt động. Không bao giờ bắt đầu sai (xem phần đính kèm).
  4. Sau khi đăng nhập, tôi chạy lệnh này cho bạn, để giúp tôi khám phá điều gì đó:

    sudo lspci | grep VGA

    Bộ điều khiển tương thích VGA 00: 02.0: Thiết bị Tổng công ty Intel 22b1 (vòng 21)

    sudo lshw -C hiển thị

       description: VGA compatible controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 21
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=i915_bpo latency=0
       resources: irq:119 memory:80000000-80ffffff memory:90000000-9fffffff ioport:f000(size=64)
    

NHƯNG

  1. Tôi muốn có một hạt nhân thời gian thực vì vậy tôi đã xây dựng một - 3,18,25-rt23
  2. Tôi thành công xây dựng một hạt nhân thời gian thực mới NHƯNG đồ họa của tôi đi sai. Trong khi khởi động, tôi có thể thấy các ký tự / chữ cái không thể đọc được và sau đó màn hình của tôi hoàn toàn đen. Linux đang chạy vì tôi có thể truy cập vào nó thông qua giao diện điều khiển nối tiếp. Serial console là OK.

Tôi không muốn hình ảnh HD, tôi không muốn máy chủ X hoặc tương tự. Tôi muốn cửa sổ đen đơn giản, ngu ngốc với các ký tự trắng và màn hình VGA và tôi không thể có nó. Tôi đã thử nhiều tùy chọn mà không thành công.

Đây là tệp / etc / default / grub thực tế của tôi:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=3
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="text"
GRUB_CMDLINE_LINUX="console=tty0 console=ttyS0,115200n8"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=1280x1024

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

CẢM ƠN BẠN, THANK YOU, CẢM ƠN BẠN để được giúp đỡ. Trên máy tính khác, tôi không có ký tự / chữ cái lạ. Nhưng tôi cần nó trên bo mạch Gigabyte N3050N-D2P của tôi!

CẬP NHẬT: Tôi nghĩ rằng đây chỉ là vấn đề hạt nhân. Tôi đã thử biên dịch lại kernel với một số thiết lập trong menu Graphics và nó tốt hơn - Tôi vẫn có một màn hình màu đen sau khi khởi động nhưng khi khởi động màn hình nhấp nháy và tôi có thể thấy một thông điệp khởi động trong giây lát rõ ràng. Nhưng màn hình nhấp nháy và sau đó lại chuyển sang màu đen.

Tôi đính kèm một hình ảnh từ màn hình khởi động của tôi:

Bắt đầu khởi động: enter image description here

Sau vài giây với kernel 3.19.0 chung enter image description here enter image description here

Khởi động với hạt nhân 3.18.25: (Bắt đầu như thế này): enter image description here

Và sau đó chỉ cần 2x flash với thông báo khởi động có thể đọc được và sau đó nó sẽ mãi mãi đen.


3
2018-02-22 22:03


gốc




Các câu trả lời:


Ok guys ... Tôi xây dựng một hạt nhân RT 4.4.1 và cuối cùng Tôi có một thông điệp khởi động và màn hình điều khiển dễ đọc, dễ đọc! NHƯNG (tại sao luôn có NHƯNG):

Đồ họa ví dụ trên alsamixer thực sự là xấu, bạn có thể cho tôi biết lý do tại sao?

uname -a

Linux ubuntu 4.4.1-rt6 #1 SMP PREEMPT RT Wed Feb 24 04:27:02 CET 2016 i686 i686 i686 GNU/Linux

sudo lshw -C hiển thị

  description: VGA compatible controller
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 2
   bus info: pci@0000:00:02.0
   version: 21
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi vga_controller bus_master cap_list rom
   configuration: driver=i915 latency=0
   resources: irq:115 memory:80000000-80ffffff memory:90000000-9fffffff ioport:f000(size=64)

sudo lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Device 22b1 (rev 21)

sudo fbset -i

mode "1280x1024"
    geometry 1280 1024 1280 1024 32
    timings 0 0 0 0 0 0 0
    accel true
    rgba 8/16,8/8,8/0,0/0
endmode

Frame buffer device information:
    Name        : inteldrmfb
    Address     : 0x900c0000
    Size        : 5242880
    Type        : PACKED PIXELS
    Visual      : TRUECOLOR
    XPanStep    : 1
    YPanStep    : 1
    YWrapStep   : 0
    LineLength  : 5120
    Accelerator : No

cat / etc / default / grub

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=3
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="text"
GRUB_CMDLINE_LINUX="console=tty1 console=ttyS0,115200n8"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=1280x1024
GRUB_GFXPAYLOAD_LINUX=text

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

ALSAMIXER trông như thế này:

enter image description here


0
2018-02-24 20:44